Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

народ помогите написать на паскале задачу под номером 7, прошу срочняк, завтра уже сдавать(

10-11 класс

Dr12340551 05 мая 2014 г., 21:58:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mikkkkki
05 мая 2014 г., 22:32:18 (9 лет назад)

Писал на Pascal ABC; Не знаю, по-ходу дела так ))

+ 0 -
Innij2779
06 мая 2014 г., 0:43:55 (9 лет назад)

А где взять кол-во пропусков?

+ 0 -
123456789100000000
06 мая 2014 г., 2:08:58 (9 лет назад)

без понятия, либо самому вводить, либо с файла txt

+ 0 -
Pelagey
06 мая 2014 г., 3:07:00 (9 лет назад)

сколько студентов ? С клавиатуры ввод ?

+ 0 -
Kimh1t666
06 мая 2014 г., 5:32:59 (9 лет назад)

ну можно и с клавы, это вот без понятия, скорее всего с клавы

Ответить

Другие вопросы из категории

Сумма M первых чисел, которые образуют последовательность

Фибоначчи по следующему правилу: F1 = 1, F2 = 1, Fn

Скажите по конкретнее, что нужно знать чтобы научиться программировать в Pascal - что именно нужно изучить...

У нас на первом курсе тема Pascal, а я гляжу на него как баран на новые ворота...
Я отстал сильно на 2 недели и ни могу ни как понять его... Скажите пожалуйста по конкретнее с чего начать, что именно нужно изучить или выучить, понять, чтобы знать как составлять на нём программы ?

Распишите каждую строчку задачи ребят, задача решена в языке С.

#include
main() {
const n=10;
int a[10]={5,3,-6,2,-4,3,-7,4,8,-9};
int i,k=0,s=0;
long p=1;
for(i=0; i if (a[i]>0) {k++; s+=a[i];}
else if (a[i]<0) p*=a[i];
printf ("kol=%d, sum=%d, prod=%d",k,s,p);
}

Читайте также

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

Народ,помогите дорешать задачу на С++,буду благодарен.

- В целочисленном массиве Х(N) удалить все элементы, расположенные между максимальным и минимальным элементами.
- Найти среднее арифметическое элементов массива до и после удаления.
- В программе написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

из выше перечисленного выводит только средне арифметическое и средне арифметическое между 1 и последним числом.




#include
float srednee(int* a, int min, int max)
{
int s = 0;
for(int i = min; i <= max; i++)
s += a[i];
return s * 1.0 / (max - min + 1);
}
using namespace std;
int min_i(int* a, int n)
{
int m = a[0];
int numb = 0;
for(int i = 1; i < n; i++)
if(m > a[i])
{
m = a[i];
numb = i;
}
return numb;
}
int max_i(int* a, int n)
{

int m = a[0];


int numb = 0;
for(int i = 1; i < n; i++)
if(m < a[i])
{
m = a[i];
numb = i;
}
return numb;
}
using namespace std;
int main()
{
int N;
cin >> N;
int X[N];

for(int i = 0; i < N; i++)
cin >> X[i];
cout << "srednee znachenie vsego massiva: " << srednee(X, 0, N - 1) << endl;
int min = min_i(X, N);
int max = max_i(X, N);
if(min > max)
{
int z = min;
min = max;
max = z;
}
if(max - min == 0 || max - min == 1)
cout << "srednee znachenie korotkogo massiva: " << srednee(X, 0, N - 1) << endl;
else
{
int delta = max - min;
for(int i = max; i < N; i++)
X[i - delta + 1] = X[i];
cout << "srednee znachenie korotkogo massiva: " << srednee(X, 0, N - delta) << endl;
system("pause");
return 0;
}
}

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.



Вы находитесь на странице вопроса "народ помогите написать на паскале задачу под номером 7, прошу срочняк, завтра уже сдавать(", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.