Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста!! надо написать программу на паскале, нужно найти номер первого положительного элемента в массиве. очень нужно

10-11 класс

Chuvak 06 дек. 2014 г., 4:20:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Superolya2011
06 дек. 2014 г., 6:44:05 (9 лет назад)

const    n=10;
var
a:array[1..100] of integer;
i,m:longint;
t:boolean;
begin
for i:=1 to n do
      begin       write('a[',i,']: ');
      readln(a[i]);
      end;

Ответить

Другие вопросы из категории

Какое наименьшее число символов должно быть в

алфавите, чтобы при помощи всевозможных трехбуквенных слов, состоящих из
символов данного алфавита, можно было передать не менее 9 различных сообщений?

1 2 5 9 основание классификации
Много баллов(78) за блок-схему...завтра курсовую сдавать :( программа на паскале uses crt; type

mas=array [1..100] of integer;

var

b:mas;

p,i,n:integer;

procedure vvod (x:mas;k:integer);

var i,p:integer;

begin

for i:=1 to n do begin

write('Vvedite chislo: ');

readln(x[i]);

end;

for i:=1 to n do

write(x[i]:3);

for i:=n downto 1 do

if x[i]<0 then

p:=i;

writeln;

write('= ',x[p-1]);

writeln;

readln;

end;

begin

clrscr;

write('Vvedite kol-vo chisel: ');

readln((n));

vvod (b,n);

readln;

end.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835



Вы находитесь на странице вопроса "помогите пожалуйста!! надо написать программу на паскале, нужно найти номер первого положительного элемента в массиве. очень нужно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.