Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

запишите все двузначные десятичные числа , каждое из которых в 10 раз больше суммы своих цифр

5-9 класс

Lbordunov 24 янв. 2015 г., 4:44:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natysik9191
24 янв. 2015 г., 7:02:25 (9 лет назад)

var 
a:array[1..10] of integer;
i,g,k:integer;
begin

for i:=1 to 10 do
readln(a[i]);

for i:=1 to 10 do begin
 g:=a[i];
k:=g mod 10;
g:=g div 10;
k:=k+g;
if g = 10*k then
 writeln(a[i]);
k:=0;
g:=0;
end;
end.























Ответить

Читайте также

1.Сколько двоек содержит десятичное число 89,

записанное в системе счисления с основанием 3.
2.Запишите десятичное число 63 в системе
счисления с основанием 7.
3.Определить старшую цифру системы счисления с
основанием 20.
4.Вычислить 1DA15 + 4349 ->9
5.Какому десятичному числу соответствует число 12228221111112223 Помогите пожалуйста с этими заданиями, если сможете то срочно надо))

1.Сколько двоек содержит десятичное число 89,

записанное в системе счисления с основанием 3.
2.Запишите десятичное число 63 в системе
счисления с основанием 7.
3.Определить старшую цифру системы счисления с
основанием 20.
4.Вычислить 1DA15 + 4349 ->9
5.Какому десятичному числу соответствует число 12228221111112223 Помогите пожалуйста с этими заданиями, если сможете то срочно надо))

Написать программу

Трехзначное число в 5 раз больше произведения своих цифр. Какое это число?

На экране есть два окна, в каждом из которых записано по числу. Исполнитель СУММАТОР имеет только две команды, которым присвоены номера: 1. Запиши

сумму чисел в первое окно 2. Запиши сумму чисел во второе окно Выполняя команду номер 1, СУММАТОР складывает числа в двух окнах и записывает результат в первое окно, а выполняя команду номер 2, заменяет этой суммой число во втором окне. Напишите программу, содержащую не более 6 команд, которая из пары чисел 1 и 2 получает пару чисел 23 и 16. Укажите лишь номера команд. Например, программа 21211 – это программа: Запиши сумму чисел во второе окно Запиши сумму чисел в первое окно Запиши сумму чисел во второе окно Запиши сумму чисел в первое окно Запиши сумму чисел в первое окно которая преобразует пару чисел 1 и 0 в пару чисел 8 и 3.



Вы находитесь на странице вопроса "запишите все двузначные десятичные числа , каждое из которых в 10 раз больше суммы своих цифр", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.