Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вводится последовательность из N положительных целых чисел, 0 – конец последовательности. Найти количество всех четных элементов последовательности.

5-9 класс

Нужна ШАЯ и программа

Sasha707 23 июня 2013 г., 11:21:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MCscope
23 июня 2013 г., 13:40:07 (10 лет назад)

var   n,i:Integer;
begin 
 i:=0;
 repeat 
 Readln(n); 
 if (n mod 2=0) and (n<>0) then
   Inc(i); 
until n=0; 
Writeln; 
Writeln(i); 
readln;
end.

Ответить

Другие вопросы из категории

1 появление первых лазерных дисков

2 первые следы иероглифического письма в Древнем Египте
3 появление первых жёстких дисков для компьютеров
4 изобретение магнитофона
5 изобретение фотографии
их дату

сколько кб в 86400 байтов

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.
Формат выходных данных
Выведите ответ к задаче.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "Вводится последовательность из N положительных целых чисел, 0 – конец последовательности. Найти количество всех четных элементов последовательности.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.