Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заполните матрицу из 8 строк и 5 столбцов случайными числами в интервале [-10;10] вывести её на экран. Найти сумму всех четных элементов

5-9 класс

Danasjn 30 янв. 2014 г., 4:31:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мария1517
30 янв. 2014 г., 5:41:26 (10 лет назад)

var a:array [1..8,1..5]of integer;

s,i,k:integer;

Begin

  randomize;

  for i:= 1 to 8 do begin

     for k:= 1 to 5 do begin

        a[i,k]:= random(20)-10;

        write(a[i,k]:3,' ');

        if a[i,k] mod 2 = 0 then s:=s+a[i,k];

     end;

     writeln;

  end;

  writeln('s=',s);

End.

    

+ 0 -
Julia
25 февр. 2018 г., 15:01:31 (6 лет назад)

Помогите пожалуйста, кто знает как делать!) Заполнить матрицу случайными числами от 3 до 8. 4 строки 6 столбцов, в этой же матрице найти количество элементов больше 5. Добавить двойной цикл который покажет индекс всех семерок и восьмерок.

Ответить

Другие вопросы из категории

Даны числа от 1 до N-нечетное. Найти Р:

1/1*1/3*…*1/N

ОПЕРАЦИОННАЯ СИСТЕМА ЭТО ПРОГРАММА ДЛЯ:

ТЕСТИРОВАНИЯ КОМПЬЮТЕРА
ОБЕСПЕЧИВАНИЯ РАБОТОСПОСОБНОСТИ КОМПЬЮТЕРА
УМЕНЬШЕНИЯ ОБЪЁМА ФАЙЛОВ

на диске D:необходимо выполнить следующую последовательность действий:

1)создать каталог мин

2)открыть каталог мин

3)создать каталог 1

4)открыть каталог 1

5)создать каталог 11

6)подняться на один уровень вверх

7)создать каталог 2

8)подняться на один уровень вверх

9)создать каталог МАХ

Изобразите файловую структуру,которая будет сформирована на диске D:после совершения этих действий.

Читайте также

Задача с помощью Паскаля: заполнить таблицу из 7 строк и 7 столбцов случайными числами в интервале [-10;10] и вывести на экран. Обнулить элементы

выделенные зеленым цветом. вот по первой картинке СЛЕВА. Вот что должно получиться:

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

Помогите,пожалуйста. Надобно написать программу в паскале.

Заполнить массив случайными числами в интервале от -10 до 10 и выполнить инверсию отдельно для 1 и 2 части.
Пример:
1 -2 6 -8 -3 | 5 -7 1 0 -4
-3 -8 6 -2 1 | -4 0 1 -7 5



Вы находитесь на странице вопроса "Заполните матрицу из 8 строк и 5 столбцов случайными числами в интервале [-10;10] вывести её на экран. Найти сумму всех четных элементов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.