Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задание заполните массив случайными числами в интервале [100..999] и переставьте их по возрастанию суммы цифр.

5-9 класс

Almas2208 03 марта 2014 г., 1:53:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юлия1104
03 марта 2014 г., 4:11:41 (10 лет назад)

var
a:array [1..10] of integer;
i,j,k:integer;
function Sum(c:integer):integer;
var s:integer;
begin
s:=c mod 10;
c:=c div 10;
s:=s + c mod 10;
s:=s + c div 10;
sum:=s;
end;
begin
randomize;
writeln('Массив:');
for i:=1 to 10 do
begin
a[i]:=random(900)+100;
write(a[i],' ');
end;
writeln;
writeln('Массив после перестановок:');
for i:=1 to 9 do
for j:=(i+1) to 10 do
if sum(a[i])>sum(a[j]) then
begin
k:=a[i];
a[i]:=a[j];
a[j]:=k;
end;
for i:=1 to 10 do
write(a[i],' ');
writeln;
end.

Ответить

Другие вопросы из категории

Кумир, цикл ПОКА

Найти сумму чисел
2+2.1+2.2+2.3=2.4+2.5+2.6+2.7+2.8+2.9+3
Помогите,пожалуйста) Очень срочно

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

С помощью Паскаля:

1.Заполните массив случайными числами в интервале [0;100] и подсчитайте отдельно среднее значение всех элементов,которые меньше 50, и среднее значение всех элементов,которые больше или равны 50.
2.Заполнить массив случайными числами в интервале [0;5]. Определить, есть ли в нем элементы с одинаковыми значениями,стоящие рядом.
3. Заполнить массив случайными числами и выполнить реверс отдельно в первой половине и во второй половине.

Помогите,пожалуйста. Надобно написать программу в паскале.

Заполнить массив случайными числами в интервале от -10 до 10 и выполнить инверсию отдельно для 1 и 2 части.
Пример:
1 -2 6 -8 -3 | 5 -7 1 0 -4
-3 -8 6 -2 1 | -4 0 1 -7 5

Заполнить массив случайными числами на интервале от -10 до +15. Распечатать исходный массив. Подсчитать количество положительных и отрицательных. Поменять

знак у каждого элемента массива. Распечатать. Посчитать количество отрицательных и положительных



Вы находитесь на странице вопроса "Задание заполните массив случайными числами в интервале [100..999] и переставьте их по возрастанию суммы цифр.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.