Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Кумир, цикл ПОКА

5-9 класс

Найти сумму чисел
2+2.1+2.2+2.3=2.4+2.5+2.6+2.7+2.8+2.9+3
Помогите,пожалуйста) Очень срочно

BowWow 24 янв. 2014 г., 8:25:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дракон98
24 янв. 2014 г., 10:11:20 (10 лет назад)

var x,s:real;
begin
x:=2;
while x<3 do 
begin
S:=S+x;
x:=x+0.1
end;
writeln (S);
readln
end.

+ 0 -
Vitalina6nastya
24 янв. 2014 г., 13:08:24 (10 лет назад)

VAR
   sum, zn: Real;
BEGIN
   sum := 0;
   zn := 2;

   While (zn <= 3) do begin
      sum := sum + zn;
      zn := zn + 0.1; end;

   Write(sum);
END.

Ответить

Другие вопросы из категории

помогите пожалуйста решить задания по информатике. Спасибо получите 100%. можно с решением пожалуйста.Задание 1.У короля было три дочери. Решил он выдать

их замуж. Пригласил женихов со всех концов света. Съехались в королевство 50 принцев и знатных юношей. Сколькими способами дочери короля могут выбрать себе женихов?
Задание2.
На одном далеком-далеком острове жило-было маленькое племя. В языке этого племени было всего 5 прилагательных, 15 существительных и 10 глаголов. Предложения в этом языке состояли либо из существительного и глагола, либо из прилагательного, существительного и глагола (порядок слов именно такой). Сколько всего предложений можно составить по правилам языка маленького племени?

Дана программа, которая вычисляет значение многочлена x3 + 3x2 – 5x + 4

при x=2
Var x, y: real;
Begin
x := 2;
y := x*x*x + 3*x*x – 5*x + 4;
writeLn(y)
End.
Оптимизируйте команду присваивания y := x*x*x + 3*x*x – 5*x + 4; что бы в ней было меньше арифметических операций.

Читайте также

Дано словесное описание алгоритма: z:=2; d:=7; k=0; Начало цикла пока d>=z

d:=d – z; k=k+1;

конец цикла;

Вывести результат на экран.

Составить блок-схему в виде циклического алгоритма. Определить количество циклов k. Написать программу на языке Паскаль с использованием оператора цикла с предусловием.



Вы находитесь на странице вопроса "Кумир, цикл ПОКА", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.