Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Для данного натурального числа N требуется вычислить сумму : 1 + 1/2 + + 1/3 + ... + 1/N. Постройте алгоритм и напишите 2 варианта программы на паскале

5-9 класс

с циклом -до и с циклом-пока

Mambetova04 18 дек. 2014 г., 9:53:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iliastepanov
18 дек. 2014 г., 10:49:32 (9 лет назад)

1) var
s:real;
i,n:integer;
begin
s:=0;
readln(n);
for i:=1 to n do
s:=s+1/i;
writeln(s);
end.

 

2) 

var
s:real;
i,n:integer;
begin
s:=0;
i:=1;
readln(n);
while i<=n do begin
s:=s+1/i;
i:=i+1;
end;
writeln(s);
end.

+ 0 -
Aggro
18 дек. 2014 г., 12:31:50 (9 лет назад)

1)

var
n,z:integer;
i,sum:real;
begin
readln (N);
while (z<>n) do
begin
z:=z+1;
i:=1/z;
sum:=sum+i;
writeln (sum);
end;
end.

 

2)

var
n,z:integer;
i,sum:real;
begin
readln (N);
repeat
z:=z+1;
i:=1/z;
sum:=sum+i;
writeln (sum);
until (z=n);
end.

Ответить

Другие вопросы из категории

составьте программу которая заполняет массив b 1..8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными

значениями
пример ввода:
исходный массив:
10 2 4 1 3 5 7 8
количество пар чётных элементов = 2 { это пары (10,2),(2,4) }

1)

Стереоаудиофайл передается со скоростью 32000
бит/с. Файл был записан с такими параметрами: глубина кодирования – 16 бит на
отсчет, частота дискретизации – 48000 отсчетов в секунду, время записи – 90 с.
Сколько минут будет передаваться файл?

Решить 122-136 по информатике

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

НУЖНО НАПИСАТЬ ПРОГРАММЫ НА ПАСКАЛЕ "циклы с условием" 1)Среди чисел 1, 4. 9. 16, 25,... найти первое число, большее n. 2)Дано число

n.

а) Напечатать те натуральные числа, квадрат которых не превышает n.

3) Дано натуральное число. Определить:

а) количество цифр 3 в нем;

г) сумму его цифр, больших пяти;

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ,НУЖНО ОЧЕНЬ СРОЧНО,: (решение задач с параметром,язык PASCAL) №1)дано натуральное n, вычислить:

а) -2/1! +3/2! -...+ (-1)^n *(n+1)/n! (n после единицы это степень)

б) 1!/1+ 2!/ (1+1/2) +....+ n!/ (1+1/2+...+1/n)

№2) дано натуральное n, действительное х, вычислить:

а) x^1 / 1! + x^2 /2+...+ x^n / n!

б)(1/2 - cosx)(2/3-(cos^2)*x)).....( n/(n+1) - (cos^n)* x))



Вы находитесь на странице вопроса "Для данного натурального числа N требуется вычислить сумму : 1 + 1/2 + + 1/3 + ... + 1/N. Постройте алгоритм и напишите 2 варианта программы на паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.