Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составте программу формирования из массива А двух массивов, в которых первый замолнен отрицательными, а второй-положительными элементами.

10-11 класс

12Надюшка21 13 февр. 2015 г., 13:58:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Samsung1186
13 февр. 2015 г., 15:21:02 (9 лет назад)

Program Pr1;
uses crt;
var mas:array[1..100] of integer;
pos:array[1..100] of integer;
min:array[1..100] of integer;
i,b,c:integer;
Begin
clrscr;
b:=0;
c:=0;
randomize;
for i:=1 to 100 do mas[i]:=-100+random(200);
for i:=1 to 100 do write(mas[i]);
writeln();
for i:=1 to 100 do if mas[i]>=0 then begin
b:=b+1;
pos[b]:=mas[i];
end
else begin
c:=c+1;
min[c]:=mas[i];
end;
writeln('Polojitelnye');
for i:=1 to b do write(pos[i]);
writeln();
writeln('Otricatylnye');
for i:=1 to c do write(min[i]);
end.

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА, ПОМОГИТЕ ОЧЕНЬ СКОРОЧНО! С РЕШЕНИЕМ НУЖНО

в студенческой группе 24 студента. Сообщение о том что староста группы девушка , содержит 3 бита информации . количество девушек в группе равно

Ребят прошу помогите умоляю

реферат на тему передача информации

Читайте также

Задача 1 Составить программу При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В

массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Задача 2

В одномерном массиве , состоящем из n вещественных элементов , вычислить ;

1) минимальный элемент массива;

2)сумму элементов массива , расположенных между первым и последним положительными элементами .

Преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Подпрограммы, Pascal ABC

Дано массивы А1(N1,M1), A2(N2,M2), A3(N3,M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов. В первом из них количество положительных элементов массивов А1,А2,А3 соответственно, во втором количество отрицательных элементов массивов А1,А2,А3 соответственно. Определение количества отрицательных и положительных элементов в исходном массиве и формирование одномерного массива осуществить в подпрограмме.



Вы находитесь на странице вопроса "Составте программу формирования из массива А двух массивов, в которых первый замолнен отрицательными, а второй-положительными элементами.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.