Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Вычислить и напечатать сумму площадей кругов с радиусом от 18 до 99.

10-11 класс

Пожалуйста, напишите способом цикл ПОКА или цикл ДЛЯ.

Ilyastore77 05 июля 2013 г., 1:55:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Фдучы
05 июля 2013 г., 2:29:11 (10 лет назад)

S = Pi * R^2

На Pascal:

program Project;
var
  sum: Integer;
  i: Integer;
begin
  sum:=0;

  for i:=18 to 99 do
    sum:=sum + (3.14 * i * i)

  WriteLn("sum s = ", sum);
end.

На C:

#include "stdio.h"

main()
{
  int sum = 0, i;
  
  for(i = 18; i <= 99; i++)
    sum = sum + (3.14 * i * i);
  
  printf("Sum(S) = %i", sum);
}

Ответить

Другие вопросы из категории

Читайте также

Задачи в Paskal ABC

1.Дан радиус окружности. Вычислить длину окружности и площадь круга, ограниченного этой окружностью.
2.Даны 2 положительных числа. Вычислить их среднее арифметическое и среднее геометрическое.

ПОМОГИТЕ! ТОЛЬКО НУЖНО РЕШИТЬ НЕ ЧЕРЕЗ if, A ЧЕРЕЗ CASE1. Пользователь вводит неотрицательное однозначное число A. Написать программу:

вычисляющую в случае ввода 1 - площадь круга с радиусом A,
вычисляющую в случае ввода 2 - площадь квадрата со стороной A,
вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,выдающую сообщение «нужно ввести число 1, 2, 3» в остальных случаях.

Игрок А объявляет двузначное число от 01 до 99. Игрок В меняет местами его цифры и прибавляет полученное число к сумме его цифр. Полученный результат он

объявляет игроку А. Игрок А проделывает с этим числом ту же процедуру, и так они продолжают поступать поочередно, объявляя числа. От суммы чисел берется остаток от деления на 100, поэтому объявляются лишь двузначные числа. Какие числа может объявить игрок А на начальном шаге, чтобы игрок В в некоторый момент объявил число 00.



Вы находитесь на странице вопроса "Вычислить и напечатать сумму площадей кругов с радиусом от 18 до 99.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.