Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста. Нужно решить через программу Pascal ABC

10-11 класс

Определить объем цилиндра и площадь его полной поверхности, если известны радиус основания и высота цилиндра.

Формулы:

Vasikas 30 авг. 2013 г., 20:05:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lera470
30 авг. 2013 г., 21:19:43 (10 лет назад)

1 задача
prograb abc;
uses crt;
var h,r:integer;
     V,S:real;
begin clrscr;
write('h=');
readln(h);
write('r=');
readln(r);
V:=pi*r*2*h;
S:=2*pi*r*(r+h);
writeln('V=',V);
write('S=',S);
end.



Ответить

Другие вопросы из категории

Составить программу на паскаль.

Слова могут содержать любые символы языка.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.



Вы находитесь на странице вопроса "Помогите пожалуйста. Нужно решить через программу Pascal ABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.