Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

задачи на оператора выбора. составить программу к задаче: Для целого числа k от 1 до 99 напечатать фразу "Мне k лет",учитывая что может быть

5-9 класс

"лет","год" ,"года"

Fktrctq1 13 окт. 2014 г., 20:06:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darishка
13 окт. 2014 г., 20:56:09 (9 лет назад)

uses crt;
var r: byte;
begin
readln(к);
write('Мне ',к);
if r in [5..20] then write(' лет') else
  case к mod 10 of
1: write(' год');
2..4: write(' года');
5..9,0: write(' лет');
else

writeln('error');
end;
end.

через case оч хорошо всё получается)

 

или вот так по подробнее:

 Const st='Мне';
Var
k: Byte;
BEGIN
Repeat
Write('Введите K (от 1 до 99): ');
Readln(k);
until k in [1..99];
Case k of
11..20: Writeln(st,' ',k,' лет');
Else
begin
Case k mod 10 of
1: Writeln(st,' ',k,' год');
2..4: Writeln(st,' ',k,' года');
5..9,0: Writeln(st,' ',k,' лет');
end;
end;
end;
Readln
END.

 

 

 

 

 

 

 

Ответить

Другие вопросы из категории

Дана непустая последовательность целых чисел, оканчивающаяся нулем

(0 является признаком окончания последовательности и в последовательность не входит).
Найти и напечатать:
1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Если таких чисел нет, то напечатать «Таких чисел нет»
2. Количество четных чисел

Читайте также

Составить программу с постусловием для нахождения произведения чисел от 1 до 15 , имеющий в остатке от деления на 3 число 2.как я поняла,это числа

2,5,8,11 и 14составить программу не могу. Прошу! от этого задания зависит моя четвертная оценка!

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции

деления (Div и Mod)
2.Составьте программу делящую переменную А=100 на 3. Деление прекратить когда остаток А будет меньше 3. Подсчитать количество вариантов деления и вынести значение на экран.

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три

четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование: Количество: Цена,руб:
Красная шапочка 500 г k
Алые паруса 200 г a
Воронежские 100 г b
Чародейка 250 г m



Вы находитесь на странице вопроса "задачи на оператора выбора. составить программу к задаче: Для целого числа k от 1 до 99 напечатать фразу "Мне k лет",учитывая что может быть", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.