Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Исправить ситаксические ошибки в программе которая в тексте меняет слово 77777 на слово 00000 Var s: string; d,i:integer;

10-11 класс

begin

s:='177777277777377777477777;

d:=length(s);

for i:=0 to d - 4 begin

if copy(s,i,5)=00000 then begin

delete(s,i,5);

end

end;

writeln(s)

end.

Nekitos911 29 апр. 2013 г., 19:58:37 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natasha79
29 апр. 2013 г., 20:35:06 (11 лет назад)

Var
s:string;
d,i:integer;
begin
s:='177777277777377777477777';
d:=length(s);
for i:=1 to d-4 do
if copy(s,i,5)='77777' then
begin
delete(s,i,5);
insert('00000',s,i);
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Упорядочить последовательность по убыванию элементов и выдать на экран все элементы, большие некоторого заданного числа. И вот как раз это некоторое

заданное число я взяла "с=2000". Не могу написать часть программы, которая бы как раз и обозначала вывод на экран последовательность чисел, которые были бы больше заданного числа.. :(

Program mas1;
uses crt;
Var a: array [1..30] of real;
i,n,P,k,c: integer;
d: real;
Begin
repeat
Write(' Введите 0 Readln(n);
if (n<0) or (n>30) then
writeln(' n неправильно введено');
until (n>=1) and (n<=30);
P:=2;
For k:=1 to n do
Begin
P:=P*(k+2);
a[k]:=P*cos(k);
end;
writeln(' Получен массив А');
for i:=1 to n do
writeln('A[',i:2,']=',A[i]:15:3);
writeln;
For i:=1 to n do
for k:=1 to n-i do
if a[k] begin
d:=a[k];
a[k]:=a[k+1];
a[k+1]:=d
end;
writeln;
writeln(' Массив по убыванию');
for i:=1 to n-1 do
writeln('A[',i:2,']=',A[i]:15:3);
writeln;
c:=2000;

?

end.

что означает ##### в excel

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Исправить ситаксические ошибки в программе которая в тексте меняет слово 77777 на слово 00000 Var s: string; d,i:integer;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.