Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найти сумму всех четырехзначных чисел в записи которых встречается хотя бы одна цифра 5

5-9 класс

настенка1601 24 июля 2013 г., 23:26:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alisher78
25 июля 2013 г., 2:01:25 (10 лет назад)

Program n1;
Uses CRT;
Var a,b,c,d,s,i: integer;
begin
For i:=1000 to 9999 do
begin
a:=i div 1000;
b:=i mod 1000 div 100;
c:=i mod 100 div 10;
d:=i mod 10;
If (a=5)or(b=5)or(c=5)or(d=5) then s:=s+i;
end;
writeln('summa ravna ',s);
readln
end.

Ответить

Другие вопросы из категории

ЗАДАЧИ НА TURBO PASCALE

1)Найти наибольшее среди 2 чисел
2)Для чисел a,b,c,d вывести на экран полусумму наибольшего и наименьшего из них.
Напишите пожалуйста программы для этих задач.

помогите составить алгоритм решения этой задачи:)

Требуется расчитать периметр прямоугольного треугольника с углом 30 градусов,по заданному катету лежащему против угла 30 градусов

Читайте также

ПОМОГИТЕ ОЧЕНЬ НАДО!

Дано целое число n, которое больше либо равно 0 и меньше либо равно 9.
Написать программу, вычисляющую сумму всех двузначных чисел в записи которых нет n.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "найти сумму всех четырехзначных чисел в записи которых встречается хотя бы одна цифра 5", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.