Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста! Срочно надо написать программу в паскале. Задание: Введите три трёхзначных числа. Найти разность между наибольшим м наименьшим.

5-9 класс

Заранее спасибо!

Jamshed161 11 марта 2014 г., 16:25:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ВЕСНА2011
11 марта 2014 г., 18:07:26 (10 лет назад)

begin
  var a, b, c: single;
  readln(a, b, c);
  writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.

Позязя, расширеннее...
begin
  var a, b, c, d, e: single;
  readln(a, b, c);
  if (a < b) then
    d := a
  else
    d := b;
  if (c < d) then
    d := c;
  if (a > b) then
    e := a
  else
    e := b;
  if (c > e) then
    e := c;
    writeln(e - d);
end.

Ответить

Другие вопросы из категории

примеры табличных процессоров
Ребята,помогите пожалуйста!!!))) суть задания: Составьте блок-схему и программу на языке VBA, которая вычисляет сумму первых n целых положительных четных

чисел. Количество суммируемых
чисел должно вводиться во время работы программы. Программа должна
проверять правильность введенных пользователем данных и, если они неверные ( n ≤ 0 ), выдавать сообщение об ошибке.
Буду очень признательна, если кто-нибудь возьмется за это задание. Спасибо)

1. Отличник

Поликарп и двоечник Колька составляли максимальное 5-значное число,
которое состоит из различных нечётных цифр. Поликарп своё число составил
правильно, а Колька ошибся — он не заметил в условии
слово "различных", и очень радовался, что его число оказалось
больше, чем число Поликарпа. Какие числа составили Поликарп и Колька?

Читайте также

Помогите пожалуйста,срочно надо

Написать программу,которая вычисляет площадь прямоугольного треугольника. Параметрами функции должны быть значения катетов.

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Ребят, помогите пожалуйста, срочно надо)))!!!!!

Составить программу для паскаля.
1) y=x^8
2) y=x^10

Помогите пожалуйста, срочно надо Составь программу на Pascal для этой задачи:

С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет


Вы находитесь на странице вопроса "Помогите пожалуйста! Срочно надо написать программу в паскале. Задание: Введите три трёхзначных числа. Найти разность между наибольшим м наименьшим.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.