Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Хэлп! Срочно!

5-9 класс

Дан ряд чисел: 1+2+2+4+8+32... (умножаем на предыдущее число). Пользователь вводит сколько должно быть чисел в этом ряду, а программа должна посчитать их сумму. Плиз, напишите в Паскале!

Zhenia7 21 сент. 2014 г., 18:45:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Меттaka
21 сент. 2014 г., 21:00:06 (9 лет назад)

var a,b,c,s,n,i:integer;
begin
readln(n);
a:=1;
b:=2;
s:=3;
for i:=3 to n do
  begin
  c:=b*a;
  s:=s+c;
  a:=b;
  b:=c;
  end;
writeln('s=',s);
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПРОШУ!!!

С помощью функции random сгенерировать целое семизначное случайное число. Определить в этом числе количество четных цифр...
зарнее благодарна)))

Помогите срочно пожалуйста

Читайте также

Срочно нужна сказка об информатике и

человеке! Буду благодарна! 6 класс Уже 4 раз пишу:с На завтра срочно нужно,не знаю что писать :ссс

Срочно! Напишите сообщение про Системный блок. Рзамером, примерно с альбомный лист.

Только содердательно и понятным языком. Срочно, пожалуйста помогите!

:)

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

пожалуйста срочно помогите, очень прошу

тема у нас Организация ветвлений в Паскале. и так, вопрос:
дано трёхзначное число. если сумма цифр числа кратно 3, тогда перевернуть число, иначе обнулить среднюю цифру
очень срочно, кто может



Вы находитесь на странице вопроса "Хэлп! Срочно!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.