Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задано время N часов и M минут. Определить через сколько минут часовая и минутная стрелки совпадут. (Написать программу на СИ)

10-11 класс

Alenka251013 17 дек. 2016 г., 3:10:38 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
діанусик
17 дек. 2016 г., 6:09:33 (7 лет назад)

#include <stdio.h>
#include <conio.h>
main()
{     
int x,y,n,z;
printf("Chasy Minuty\n");
scanf ("%d%d",&x,&y);
x=x*5;
if (x>y)

while (x<y) 
{ y++;} 
printf ("%d",y);
}     
else     
{
z=60-y;       
y=0;      
while (x>y)     
{y++;}     
printf ("%d",z+y);      }     

getch();
}


Достаточно сыро,но думаю принцип поймешь и сам доработаешь ;)

+ 0 -
Koren010
17 дек. 2016 г., 9:02:57 (7 лет назад)

щас попробуем)

+ 0 -
87770463514
17 дек. 2016 г., 11:38:30 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите пожалуйста! В паскале.

Составьте блок-схему
алгоритма и программу вычисления периметра, медианы и площади
равностороннего треугольника.

Дан

массив из N вещественных чисел. Выделить другим цветом все его
элементы, принадлежащие интервалу [a,b]

Читайте также

Создать на Паскале форму.

1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
2. Составить программу определения, является ли введенный год високосным?
3. Составить программу определения размера денежного вклада через t лет после его внесения, если заданы размер начального взноса n и банковский процент b.
4. Для условий из предыдущей задачи определить, через сколько лет размер вклада превысит вдвое первоначальный взнос.

Заданы 2 значения натурального числа N(0<=N<=100000000), записанные в десятичной системе счисления с неизвестным основанием A(2<=A<=16).

Написать программу на, которая определяет неизвестное основание системы счисления.

Написать программу на языке Paskal Заданы диаметр круга D и сторона квадрата А. Определить, поместится ли круг в квадрате. Задачу проверить

при

а) D=70, A=36

б) D=8, A=64

Квадрат поместится в круге, если диаметр окружности меньше или равен стороне квадрата. Результат вывести на экран.

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

//23. Определить что будет напечатано в результате выполнения фрагмента программы:

int[] mas = new int [] {-1, 0, 2, -8, 4, -9, 3, -4, 9, -3 };
int i = 0;
while (mas[i] < 0)
{ i++; Console.WriteLine(mas[i]);}

//24.Определить что будет напечатано в результате выполнения фрагмента программы:
int[] mas = new int[] { -1, 0, 2, -8, 4, -9, 3, -4, 9, -3 };
int i = 5;
do i--; while (mas[i] > 0);
Console.WriteLine(i);

//25.Определить что будет напечатано в результате выполнения фрагмента программы: int[] mas = new int[] { -1, 0, 2, -8, 4, -9, 3, -4, 9, -3 };
int k = 0; foreach (int el in mas)
if (el > 0) k+=el;
Console.WriteLine(k);



Вы находитесь на странице вопроса "Задано время N часов и M минут. Определить через сколько минут часовая и минутная стрелки совпадут. (Написать программу на СИ)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.