Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан одномерный массив A размерностью N(<=0). Значение массива ввести с клавиатуры, заполнить массив с помощью генератора случайных чисел. найти среднее

10-11 класс

арифметическое и количество всех положительных элементов массива))
Помогите составить программу в Паскале, буду благодарна:)

Ната2695 31 янв. 2015 г., 2:39:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashams280
31 янв. 2015 г., 5:27:30 (9 лет назад)

program Program1;
var i, n: integer;
var result1, result2, sum: real;
var array1: array [0..1000] of real;
begin
     randomize;
     result1 := 0;
     sum := 0;
     write('Введите значение N (не менее 0 и не более 255): ');
     readln(n);
     for i := 1 to n do
         begin
          array1[i] := random(1000) - random(1000);
         end;
         begin
          writeln('Массив размером - ', n, ' элементов(а):');
          for i := 1 to n do write(array1[i], ' ');
          writeln;
         end;
     for i := 1 to n do
         begin
          if array1[i] > 0 then result1 := result1 +1;
         end;
     for i:=1 to n do sum := sum + array1[i];
     result2 := sum / n;
     writeln('Количество положительных элементов массива = ', result1);
     writeln('Среднее арифметическое = ', result2);
end.

Ответить

Другие вопросы из категории

МАКРИЦА

даны целые положительные числа m,n и k. сформировать целочисленную матрицу размером m*n, у которой все элементы имеют значения k+i+j (i=1,2..m;j=1,2..n)

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К



Вы находитесь на странице вопроса "Дан одномерный массив A размерностью N(&lt;=0). Значение массива ввести с клавиатуры, заполнить массив с помощью генератора случайных чисел. найти среднее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.