Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заполнить одномерный массив из 40 элементов в интервале от -80 до 55.Найти max и min элементы массива.

5-9 класс

Волкадав990 01 сент. 2014 г., 0:34:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КСЮШКАКСЮШКА
01 сент. 2014 г., 3:26:13 (9 лет назад)

var 
a:array[1..40]of integer;
i:byte;
b,c,min,max:integer;
begin
for i:=1 to 40 do
 a[i]:= -80 + random(55);
min:=a[1];
max:=a[2];
for i:=1 to 40 do begin
if a[i]<min then begin
min:=a[i];
b:=min;
end;
if a[i]>max then begin
max:=a[i];
c:=max;
end;
end;
writeln('максимальный эл.= ', c);
writeln('минимальный эл.= ', b);
end.

Ответить

Другие вопросы из категории

Помогите сделать таблицу
1024 Кбайт=байт? 1111111111
На полустанке одноколейной железной дороги остановился поезд в составе тепловоза и трёх вагонов, доставивший бригаду рабочих для строительства

второго пути. Пока же на этом полустанке имеется небольшой тупик, где принеобходимости может поместиться тепловоз с вагоном или два вагона. Вскоре к тому же полустанку подошёл грузовой состав ( тепловоз и 7 цистерн). Как пропустить пассажирский поезд?

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Очень надо

Составьте программу , которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет их сумму

Помогите решить

Создать файл «U.txt», состоящий из Nцелых случайныхчисел, принадлежащих интервалу от 5 до 55. С
элементами созданного файла выполнить следующие операции:



Вы находитесь на странице вопроса "Заполнить одномерный массив из 40 элементов в интервале от -80 до 55.Найти max и min элементы массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.