Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

5-9 класс

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

SofaGolub 29 мая 2013 г., 1:13:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
5снег
29 мая 2013 г., 2:55:13 (10 лет назад)

Два в одном:

var

  a: array [1..10] of integer;

  s, i, max: integer;

 

begin

  max:= - 16;

  for i:= 1 to 10 do

  begin

    a[i]:= random(50) - 15;

    writeln(a[i]);

    s:= s + a[i];

    if a[i] > max then max:= a[i];

  end;

  writeln('Сумма элементов массива: ', s);

  writeln('Максимальный элемент массива: ', max);

end.

  

+ 0 -
Teamonis
29 мая 2013 г., 4:15:43 (10 лет назад)

 

program Mas1;

  uses Crt;

  const n:=10;

  Type Ar=array [1..n] of real;

  var v:Ar;

        s,max:real;

        i:integer;

Begin

   Clrscr;

   s:=0;

   max:=0;

   i:=1;

   For i:=1 to n do

    begin

    v[i]:=50*random-15;

    s:=s+v[i];

    If max<v[i] then max:=v[i];

    end;

   writeln ('S= ', s:6:2,'   Max=  ', max);

Readln;

End.

 

   

Ответить

Другие вопросы из категории

Постройте алгоритм и составьте программу, по которой будет реализован следующий сценарий: компьютер запрашивает номер дня недели, после ввода компьютер

сообщает название этого дня. Например, если ввели 1, то выведется фраза «Это понедельник» и т. д.

Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время

прибытия самолета в аэропорт назначения в виде «чч:мм» Формат входных данных: С клавиатуры вводится четыре числа через пробел НН, ММ, НР, МР, обозначающие соответственно часы и минуты вылета и часы и минуты продолжительности полета. Формат выходных данных: На экран вывести время прибытия самолета в аэропорт назначения в виде «чч:мм

Читайте также

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ: 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного

типа. Ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ". 3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д состоящего из 10 элементов целого типа. Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса



Вы находитесь на странице вопроса "ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.