Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

5-9 класс

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

Shinaika 30 июля 2013 г., 7:41:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alenamykaseva
30 июля 2013 г., 10:01:46 (10 лет назад)

var t:array[1..10] of integer;
min,i,j,k,l:integer;
Begin
    Randomize;
    min = 100;
    for i := 1 to 10 do begin
        t[i]:=random(200)-100;
        if t[i]>0 and min>t[i] then
            min:=t[i];
    end;
    writeln('min=', min);

    min= 1000;
    for i := 1 to 9 do begin
        for j := i+1 to 10 do begin
            if abs(t[i]-t[j])<min then begin
                k:=i;
                l:=j;
                min:=abs(t[i]-t[j]);
            end;
        end ;       
    end;    
    writeln('i,j=', k,l, t[k], t[l]);
End.

Ответить

Другие вопросы из категории

Помогите пожалуйста! Нужно вытянуть оценку!!!

Напишите процедуру ввода N элементов массива из файла. Отсортируйте по невозрастанию методом простого обмена. (Паскаль)

Читайте также

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

Помогите, пожалуйста, решить задачи на языке программирования в Turbo Pascal. 1) Определить максимальн

ый элемент квадратной матрицы, расположенный в правой части, ограниченной диагоналями, включая диагональные элементы.

2) Дана таблица с оценками 12 учащихся по девяти предметам. Определить номер предмета, содержащий максимальный средний балл.

Решить задания на языке программирования в Turbo Pascal: 1) Выполните тестирование программы: опишите как будут меняться значения переменных и

что появится на экране в результате выполнения программы. Для переменной S ввести строку - 'аб2в457где245*ж'

Program z2;

uses crt;

var s:string;

k,sum,i,n:integer;

begin

readln(s);

i:=1;

repeat

val(s[i],n,k);

i:=i+2;

sum:=sum+n;

writeln(n);

until i>length(s);

writeln(sum);

readkey;

end.

2) Дано предложение. Удалить из него все буквы с

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.