Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

. Даны координаты трех вершин треугольника, описать их как записи. Найти длины сторон этого треугольника.

10-11 класс

Slavavychegzha 22 сент. 2014 г., 23:03:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Prokopevanasty
23 сент. 2014 г., 0:17:55 (9 лет назад)


Program qfdw;
uses crt;
Type
   vershina=Record
       Tochka:string;
       X,Y:real;
     end;
   ps=File of vershina;
Var f:ps;
    z,a,b,c:vershina;
  i:integer;
Begin
  assign(f,'1.dat');
  rewrite(f);
  writeln('Введите вершины треугольника и их координаты: ');
  for i:=1 to 3 do
    begin
      writeln(i,'-я вершина');
      write('буква: ');read(z.tochka);
      write('X=');read(z.x);
      write('Y=');read(z.y);
      write(f,z);
    end;
  Close(f);
  assign(f,'1.dat');
  reset(f);
  read(f,a);  
  read(f,b);  
  read(f,c);  
  close(f);
  writeln('Cтороны треугольника:');
  writeln(a.tochka,b.tochka,' = ',sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)):5:2);
  writeln(c.tochka,b.tochka,' = ',sqrt((c.x-b.x)*(c.x-b.x)+(c.y-b.y)*(c.y-b.y)):5:2);
  writeln(a.tochka,c.tochka,' = ',sqrt((a.x-c.x)*(a.x-c.x)+(a.y-c.y)*(a.y-c.y)):5:2);
end.

Ответить

Другие вопросы из категории

помогите!!!!!

Написать программу, которая вводит с клавиатуры произвольное число N,обозначающее количество студентов в спортивной команде. Затем запрашивает ввод Nстрок, в каждой из которых – информация об одном студенте в таком формате: <Фамилия><Имя> <Рост>. Вывести студентов в порядке возрастания их роста.

Производится двухканальная (стерео) звукозапись с частотой дискретизации 11 кГц и глубиной кодирования 16 бит. Запись длится 6 минут, ее

результаты записываются в файл, сжатие данных не производится. Какое из приведенных ниже чисел наиболее близко к размеру полученного файла, выраженному в мегабайтах?

Читайте также

Даны координаты трех точек на плоскости:

A(-12,57;-10,23),B(3,3;12,47),C(15,67;-10,32).Найдите с точностью до одного знака после запятой площадь треугольника АВС. В ответе укажите только число,отделяя дробную часть от целой запятой без пробелов,например,13,2



Вы находитесь на странице вопроса ". Даны координаты трех вершин треугольника, описать их как записи. Найти длины сторон этого треугольника.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.