Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны координаты трех точек на плоскости:

10-11 класс

A(-12,57;-10,23),B(3,3;12,47),C(15,67;-10,32).Найдите с точностью до одного знака после запятой площадь треугольника АВС. В ответе укажите только число,отделяя дробную часть от целой запятой без пробелов,например,13,2

Zeryutin 14 марта 2014 г., 21:39:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
5599shkno
14 марта 2014 г., 23:24:39 (10 лет назад)

Формула площади треугольника, вершины которого заданы своими координатами, известна:
S_{\Delta}= \displaystyle \left |\frac12[(x_1-x_3)(y_2-y_3)-(x_2-x_3)(y_1-y_3)]\right|

var
  x1,x2,x3,y1,y2,y3,s:real;
begin
  Writeln('Введите x1,y1,x2,y2,x3,y3');
  Readln(x1,y1,x2,y2,x3,y3);
  s:=abs((x1-x3)*(y2-y3)-(x2-x3)*(y1-y3))/2;
  Writeln('Площадь треугольника равна ',s:0:1)
end.

Результат решения:
Введите x1,y1,x2,y2,x3,y3
-12.57 -10.23 3.3 12.47 15.67 -10.32
Площадь треугольника равна 321.2



Ответить

Другие вопросы из категории

Дана последовательность чисел a1, a2, …, an. Требуется переставит числа в поряд-ке возрастания. Для этого сравниваются два соседних числа ai и ai+1. Если

ai>ai+1 то делается пере-становка. Так продолжается до тех пор, пока все элементы не станут расположены в порядке воз-растания. Составить алгоритм сортировки, подсчитывая при этом количество перестановок.
ПОМОГИТЕ СДЕЛАТЬ В ПАСКАЛЬ, ПРОШУ =*(

ПОМОГИТЕ ПОЖАЛУЙСТА УМОЛЯЮ

.Получить
двоичный код из вещественного числа 0.125

Как изменится формула =2*А2+$В4-3*$А&6, находящийся в ячейке табличного процессора при копировании ее в ячейку на 2 позиции правее и на 3 позиции вниз

от текущей? Выберете верный ответ.
а) =2*А2+$В7-3*$А$6 б) =2*С5+$В10-3*$А$6 в) =2*С5+$В7-3*$А$6 г) =2*С5+$В7-3*$С$6
Помогите, пожалуйста с:

Читайте также

написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,

которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от
того, лежит ли точка внутри заштрихованной области, вне заштрихованной области
или на ее границе.

Решите головоломку.Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Причем: А - фрагмент

оперативной памяти размером в 16 байтов; В – конечное число точек на плоскости, соединённых отрезками кривых линий; С – единица измерения расстояния; Д – аргумент или результат процедуры.В ответе запишите найденные слова: сначала А, затем, В, С и Д, через один пробел, без знаков препинания.



Вы находитесь на странице вопроса "Даны координаты трех точек на плоскости:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.