Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны координаты 2 точек на плоскости. Определить расстояние между ними. (координаты- x1;y1 и x2;y2), конечная формула должна выглядеть так: d= корень

10-11 класс

квадратный из выражения (x2-x1)^2 + (y2-y1)^2

Glojs 05 апр. 2015 г., 11:19:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sanek124
05 апр. 2015 г., 12:54:20 (9 лет назад)

Program num1;

Uses crt;

Var

x1,x2,y1,y2 : real;

d:real;

Begin

clrscr;

write('x1=');readln(x1);

write('y1=');readln(y1);

write('x2=');readln(x2);

write('y2=');readln(y2);

d:=sqrt(sqr(x2-x1)+sqr(y2-y1));

write('D=',d)

End.

 

Ответить

Другие вопросы из категории

Читайте также

Даны координаты трех точек на плоскости:

A(-12,57;-10,23),B(3,3;12,47),C(15,67;-10,32).Найдите с точностью до одного знака после запятой площадь треугольника АВС. В ответе укажите только число,отделяя дробную часть от целой запятой без пробелов,например,13,2

Дано множество точек с координатами на плоскости.

Написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.

Написать программу ПАСКАЛЬ вычисления расстояния между населёнными пунктами. 1)Вычислите расстояние между населёнными пунктами. 2)введите

исходные данные

3)масштаб карты 120 (кол-во км в одном см)

4)расстояние между точками изображающими населённые пункты если между ними 3.5 (см)...(должно выйти 420км)

5) расстояние между насел. пунктами ... км

Напишите пожалуйста программу. К завтрашнему дню надо. С Паскалем проблемы



Вы находитесь на странице вопроса "Даны координаты 2 точек на плоскости. Определить расстояние между ними. (координаты- x1;y1 и x2;y2), конечная формула должна выглядеть так: d= корень", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.