Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дано трехзначное число. определить является ли средняя цифра делителем суммы первой и последней цифр

5-9 класс

Uzlipat 18 окт. 2014 г., 16:32:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mariamaksv
18 окт. 2014 г., 17:28:43 (9 лет назад)

var x,i,x1,x2,x3:integer

s:string;

Begin

  read(x);

  s:=str(x);

  x1:=int(s[1]);

  x2:=int(s[2]);

  x3:=int(s[3]);

  if (x1+x3)mod x2=0 then writeln("да")

  else writeln("нет");

End.

Ответить

Другие вопросы из категории

Даны 4 целых числа, записанные в двоичной системе:

10101011 2, 11001100 2, 11000111 2, 11110100 2.
Сколько среди них чисел, меньших, чем BC16 +20 8

Помогите срочно, подробно решите задачу))

В течении 4 минут производится двухканальная запись результаты которого записываются в файл, размер полученного файла 40 мбайт (с точностью до 10 мб) сжатие файла не производилось, среди перечилсенных режимов укажите тот в котором производилось звукозапись:
1) Частота дискретизации 16 Мгц 24-х битное разрешение
2)Частота дискретизации 16 Мгц 16-и битное разрешение
3) Частота дискретизации 32 Мгц 24-х битное разрешение
4) Частота дискретизации 32 Мгц 32 16-и битное разрешение

Читайте также

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "дано трехзначное число. определить является ли средняя цифра делителем суммы первой и последней цифр", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.