Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Осуществить ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых

5-9 класс

положительных чисел. Использовать оператор repeat.

XhelloXD 05 марта 2015 г., 6:47:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
199785
05 марта 2015 г., 7:21:29 (9 лет назад)

program z8_1;
uses crt;
var
i:shortint;
k,n:byte;
s:integer;
sa:real;
begin
clrscr; i:=1;
repeat
read(i);
if i>0 then begin
k:=k+1;
s:=s+i;
end;
until i=0;
sa:=s/k;
write('Количество чисел:',k,' Сумма чисел:',s,'Среднее арифметическое:',sa:4:2);
readkey
end.

Ответить

Другие вопросы из категории

ИНФОРМАТИКА,РЕШИТЬ ЗАДАЧИ ,помогите решить,пожалуйста,хоть несколько!

1.Даны 3 целых числа-А,В,С. Вычислить их сумму и произведение
2.Вывести на экран случайное число от 0 до 10
3.Вывести на экран двузначное случайное число
4. Найти сумму цифр двузначного числа

1. Определить принадлежит ли введенное с клавиатуры число интервалу (0,5)
2.Ввести число с клавиатуры. Если оно положительно,то найти квадрат этого числа,если отрицательно-модуль.
3.Найти большее из двух чисел ,заданных случайным образом из интервала [-7;23]
4.Ввести двузначное число с клавиатуры. Четна ли сумма его цифр?
5. Ввести трехзначное число. Расположить цифры в порядке возрастания

Проведите арифметические операции со следующими числами:

а) 1101010 1_{2} +101110 1_{2}
б) 100110 1_{2}-1011 1_{2}
в) 100011 1_{2} +11110 1_{2}
г) 111011 0_{2} +11011 1_{2}

Читайте также

"сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое

чило меньше","Мое число больше","Вы угадали".процесс повторяется до тех пор пока не будет угадано число.

помогите на паскале сделать

ПОМОГИТЕ НАПИСАТЬ ХОТЯ БЫ ОДНУ ЗАДАЧУ НА Pascal ОНИ НЕ СЛОЖНЫЕ , А Я ДАЮ МНОГО ПУНКТОВ!! За 2 лучший ответ! Без плагиата! 1.Написать

программу,используя оператор цикла While,которая будет вводить целые положительные числа не превышающие 100. Найти сумму квадратов чисел 2.Написать программу используя оператор цикла Repeat,которая будет вводить целые числа до тех пор пока не будет введён 0.Подсчитать среднее арифметическое введённых чисел.



Вы находитесь на странице вопроса "Осуществить ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.