Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

"сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое

5-9 класс

чило меньше","Мое число больше","Вы угадали".процесс повторяется до тех пор пока не будет угадано число.

помогите на паскале сделать

AlinaWheat 19 окт. 2014 г., 14:38:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Magomed25
19 окт. 2014 г., 16:27:58 (9 лет назад)

var
a,answer:integer;
begin
randomize;
a:=random(101);
while (a<>answer) do
begin
readln (answer);
if (answer>a) then writeln ('Загаданное число меньше') else writeln ('Загаданное число больше');
end;
writeln ('Вы угадали число!');
end.

Ответить

Другие вопросы из категории

Помогите решить задание номер 7 конспект

Заранее СПС

1. На двухцветном светофоре горит красный цвет. Какой объем информации несет сообщение о том, что загорится зеленый?

2. Необходимо отгадать слово, состоящее из 4 букв и записанное с помощью алфавита из 32 букв. Каждая буква угадывается по отдельности. За один ход можно получить ответ "да" или "Нет". За сколько ходов можно отгадать слово при оптимальной стратегии игры?
3. Книга состоит из 64 страниц. На каждой странице 256 символов. Какой объем информации в килобайтах содержится в книге, если используемый алфавит состоит из 32 символов?
4.Сообщение на языке племени Мульти содержит 128 символов, занимающих 1/16 часть килобайта. Сколько символов содержит алфавит племени Мульти?

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

Отгадывая целое число, задуманное в промежутке

от 1 до 100, можно задавать вопросы, на которые вы получаете ответ
"да" или "нет". Какое максимальное число вопросов
достаточно задать, чтобы наверняка отгадать задуманное число?
100,7,8 или 16
помогите очень надо



Вы находитесь на странице вопроса ""сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.