Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан одномерный массив А размерности n поменять местами минимальный и максимальный элемент. работа в бейсике

10-11 класс

Про100Маня2002 27 дек. 2015 г., 12:39:27 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelasatr
27 дек. 2015 г., 15:34:11 (8 лет назад)

Массив это можно сказать тоже самое что и переменная , но массив отличается от переменной тем , что если переменная хранит одно значение , то в свою очередь массив хранит несколько значений. Нужно из массива А вытащить значения, сравнить их if (первое значение) > (второго значегия) то выводишь первое значение , иначе выводишь второе значение , блин я в бэйсике 0, на pho пример :
<?php
$array = array(
"a" => "8",
"b" => "4"
);
If($array["a"] > $array["b"]){
echo array["a"];
else{echo array["b"];}
?>

Ответить

Другие вопросы из категории

Что такое программное обеспечение?

* совокупность программ, которые используются в ходе разработки, корректировки или развития других прикладных или системных программ

1) написать программу, вычисления значений функции Y=1/X+2 с шагом 0,1. значения аргумента беруться из [-1;1]... 2) заполнить таблицу значений функции

y=sqrt(1/2x-1)+2 c шагом 0,1. значения аргумента беруться из [0;3,8]. предстоит продумать вопрос вывода результата... найти значение x, при котором функция не определена..

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Дан одномерный массив A размерностью N(<=0). Значение массива ввести с клавиатуры, заполнить массив с помощью генератора случайных чисел. найти среднее

арифметическое и количество всех положительных элементов массива))
Помогите составить программу в Паскале, буду благодарна:)

Помогите пожалуйста, нужно сделать в паскале, в экселе, и блок-схему!

(задание номер 5 на фото)

Дан одномерный массив А размерностью 16. Определить максимальное значение среди нечетных элементов массива, и минимальное среди четных элементов массива. Получить сумму максимального и минимального значений элементов массива и преобразовать данный массив по принципу из значений нечетных элементов вычесть сумму, а к четным элементам прибавить сумму. Все первоначальные элементы массива вводятся с клавиатуры.



Вы находитесь на странице вопроса "дан одномерный массив А размерности n поменять местами минимальный и максимальный элемент. работа в бейсике", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.