Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите)) Для заданного натурального числа N вычислить значение его факториала N!=1*2*3...*N

10-11 класс

BigArt 20 нояб. 2016 г., 10:27:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KseniAaaaaart
20 нояб. 2016 г., 12:34:00 (7 лет назад)

var a:array [1..1000] of integer;

fac,i,n: integer;

begin

readln(n);

fac:=1;

for i:=1 to n do begin

a[i]:=i;

end;

for i:=1 to n do begin

fac:=fac*a[i];

end;

writeln(fac);

end.

Ответить

Другие вопросы из категории

Помогите решить. Срочно
Дан двумерный массив размером 5*6, заполненный целыми числами с клавиатуры. Сформировать одномерный массив, каждый элемент которого равен произведению

четных положительных элементов соответствующего столбца.

Дан двумерный массив размером 4*4, заполненный вещественными числами с клавиатуры. Сформировать одномерный массив, каждый элемент которого равен количеству отрицательных элементов соответствующей строки.

Дан двумерный массив размером 6*3, заполненный целыми числами с клавиатуры. Сформировать одномерный массив, каждый элемент которого равен наибольшему по модулю элементу соответствующего столбца.

Дан двумерный массив размером 5*6, заполненный случайными числами в диапазоне [-10;10]. Сформировать одномерный массив, каждый элемент которого равен первому четному элементу соответствующего столбца, если такого не, то равен нулю.

РЕШИТЕ ЛЮБУЮ ИЗ 4-х ЗАДАЧ, ПОЖАЛУЙСТА!!

Читайте также

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "помогите)) Для заданного натурального числа N вычислить значение его факториала N!=1*2*3...*N", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.