Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вво- дятся с клавиатуры; a>=200);

5-9 класс

Ghost8080 13 авг. 2014 г., 5:51:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alcatel2804
13 авг. 2014 г., 8:31:15 (9 лет назад)

var     
 A,i:integer; 
    S:integer; 
     Sr:real; 
    b:integer;
begin 
   writeln('Введите а:'); 
   readln(A);   
  b:=200;   
 for i:=A to 200 do
 begin 
   S:=B+i; 
 End;
     Sr:=S/A; 
   writeln('Среднее значение:',sr);
end.

Ответить

Другие вопросы из категории

программа на языке паскаль

s =1 ^{2} + 2 ^{2} +3^{2}+...n^{2}
надо использовать for i= 1 to 10 do

В программе требуется выполнение операций +, / над переменными Sharik, Pirojok. В каком случае программа не выдаст ошибку при выполнении любой из

операций над заданными значениями переменных? Порядок следования операндов: Sharik+Pirojok или Sharik / Pirojok.

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Найти:

Сумму кубов всех целых чисел от 1 до n ( Значение n вводится с клавиатуры;B>a)



Вы находитесь на странице вопроса "Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вво- дятся с клавиатуры; a&gt;=200);", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.