Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу для Паскаля : дан массив n чисел.Найти сумму чисел больше заданного числа a

5-9 класс

Nataliadianova 12 апр. 2013 г., 14:57:42 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MDmitriy
12 апр. 2013 г., 15:38:34 (11 лет назад)

program zadacha; 
uses crt; 
var b: array [1..n] of integer; 
s,a,i:integer; 

begin 
clrscr; 
s:=0; 
randomize; 
write('Vvedite chislo a: '); 
readln(a); 
for i:=1 to 5 do begin 
b[ i ]:=random(201)-100; 
writeln(i,' element massiva a raven : ',b[ i ]); 
if (b[ i ]>a) then s:=s+b[ i ]; 
end; 
writeln('Summa elementov massiva ravna : ',s); 
readln; 
end.

Ответить

Другие вопросы из категории

решите задачи плиз замазку для окон готовят из смеси мела и олифы. Мела берут в 4 раза больше,чем олифы. Сколько граммов каждого из этих вещевств надо

взять,чтобы приготовить 850 грамм замазки?

вторая задача

для приготовления клюквенного киселя сахар,крахмал,клюкву и воду берут в пропорции 3/1/3/25. Сколько граммов каждого продукта надо взять,чтобы приготовить 6 порций киселя по 200 грамм?

Три одноклассника - Влад, Тимур и Юра, встретились спустя 10 лет после окончания школы. Выяснилось, что один из них стал врачом, другой физиком, а третий ю

ристом. Один полюбил туризм, другой бег, страсть третьего - регби.Юра сказал, что на туризм ему не хватает времени, хотя его сестра — единственный врач в семье, заядлый турист. Врач сказал, что он разделяет увлечение коллеги.Забавно, но у двоих из друзей в названиях их профессий и увлечений не встречается ни одна буква их имен.Определите, кто чем любит заниматься в свободное время и у кого какая профессия.

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "Написать программу для Паскаля : дан массив n чисел.Найти сумму чисел больше заданного числа a", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.