Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задан массив надо найти сколько раз меняется знак элементов.

10-11 класс

Pechenyaaa 23 дек. 2013 г., 8:31:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nasta20021
23 дек. 2013 г., 9:29:50 (10 лет назад)

на паскале?

если да то элементано 

m:=0;

for i:=1 to N-1 do

if ((a[i]>=0) and (a[i+1]<0)) or ((a[i]<0) and (a[i+1]>=0))

then  m:=m+1;

writeln('Znak menyaetsa ',m,' raz');

end. 

 

Описание

a[i] массив

N это конастанта, а точнее кол-во элементов массива

i элемента массива

m счетчик, изменения переменных

надеюсь 1 часть сам сможешь написать

Ответить

Другие вопросы из категории

однажды жители Лилипутии решили выяснить,сколько необходимо слив,чтобы уравновесить яблоко. при этом лилипуты выяснили,что яблоко уравновешивается на

чашечных весах персиком и сливой. два андерса уравновешиваются тремя персиками. яблоко и слива уравновешиваются ананасом. помогите лилипутам решить задачу.

Иван Иванов хотел закачать себе на компьютер файл размером 2,2 Гбайта. Скорость закачки файла у него в сети была 310Кбит/секунду. После того, как он

закачл ровно половину файла, скорость увеличилась в три раза. Какое время ему понадобится, чтобы скачать весь файл. Ответ записать в часах.

Программу на Си. Найти

все трехзначные числа, сумма цифр которых равна данному целому числу.

Читайте также

Паскаль

Задан целочисленный массив A[n]. Определить, сколько раз меняется знак в данной последовательности чисел, запомнить номера позиций, в которых происходит смена знака.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

ПОМОГИТЕ!ПОЖАЛУЙСТА! 1. Во сколько раз увеличится информационная емкость файла, содержащего растровое изображение, если повысить глубину его цвета со

стандарта «черно-белое» до стандарта «65 536 цветов»? 1) 8 2) 16 3) 32 4) 64 2. Во сколько раз увеличится информационная емкость файла, содержащего растровое изображение, если повысить глубину его цвета со стандарта «черно-белое» до стандарта «4 294 967 296 цветов»? 1)8 2)16 3)32 4)64 3. Какой объем памяти видеокарты займет изображение 12-разрядного файла типа BMP, экранный размер которого 1024 х 768 пикселей? 1) 3 Кбайт 2) 24 Кбайт 3) 3 Мбайт 4) 24 Мбайт

Сколько раз выполнится тело цикла в каждом фрагменте программы?

1. For i :=1 to 7 do S := S + i * i;
2. For x := -3 to 5 do 5 do K := K+ABS(X);
3. For a := 10 downo 2 do P :=P*a;
4. For i := 2 to 6 do
begin
K:=K+1;
S:=K+i;
end;

Сколько раз выполнится тело цикла, и чему будут равны значения встречающихся в программе переменных после выполнения каждого фрагмента программы?

5. i :=2; S:=0;
While S<0 do begib S:= S+i; i:+2; end;

6. x:=1 ; S:=10 ;
While x <=10 do x:=x*2 ;
S:= S+x

7. a:=0; S:=0 ;
While a> 0 do S :=S +a;
a:=a+1;

8 . a:=1;
Repeat
R := 2*a;
a:= a+1 ;
until R < 1;

9. a:=1; b:=1;
While a+b < 8 do begin a :=a+1; b := b+2 end;
S := a+b;

10. S:=0; P:= 10; k:= 1;
Repeat
S:= S+k*k;
k :=k+2;
until S > P;

11. For i :=2 to 6 do begin
K:= K+1; S:= K+i;
end;

12. for i:= 1 to 4 do S :=S+i*i; S: S*2;



Вы находитесь на странице вопроса "Задан массив надо найти сколько раз меняется знак элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.