Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Вывести все числа степени двойки, начиная с двух до 512. Записать программу

5-9 класс

Eskeofficial 18 мая 2013 г., 11:14:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Xaliullinaolga30
18 мая 2013 г., 14:06:27 (10 лет назад)

#include <stdio.h>
int main()
{
    int a = 2;
    while(a<1000)
    {
         printf("%d ",a);
         a*=2;
    }
return 0;
}

Ответить

Другие вопросы из категории

1.Назовите вид информации и носитель:

письмо друга.2. Среди перечисленных ниже устройств выпишите устройства вывода информации.
клавиатура,монитор,мышь,сканер,принтер,колонки.3. среди представленных нижу устройств выпишите устройства передачи информации
телеграф,интернет,диск,компьютер,дискета.НАПИШИТЕ ПОЖАЛУЙСТА

Читайте также

1) Вывести все числа от a до b,но заранее неизвестно, a>b или a<b

2) Вывести нечётные числа из диапозона [a,b],где a и b могут быть как чётными,так и нечётными,а также отрицательными,но обязательно a<b
3) В одной программе посчитать две суммы из [a,b] (те же условия,что и в задании 2)
S-сумма всех нечётных чисел
Sym-сумма чисел,кратных 3
Cами числа выводить не нужно
4)Найти a в степени n,где a и n целые числа, но могут быть отрицательными

(задачи можно делать либо через For,либо через While)

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,



Вы находитесь на странице вопроса "Вывести все числа степени двойки, начиная с двух до 512. Записать программу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.