Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1) Вывести все числа от a до b,но заранее неизвестно, a>b или a<b

5-9 класс

2) Вывести нечётные числа из диапозона [a,b],где a и b могут быть как чётными,так и нечётными,а также отрицательными,но обязательно a<b
3) В одной программе посчитать две суммы из [a,b] (те же условия,что и в задании 2)
S-сумма всех нечётных чисел
Sym-сумма чисел,кратных 3
Cами числа выводить не нужно
4)Найти a в степени n,где a и n целые числа, но могут быть отрицательными

(задачи можно делать либо через For,либо через While)

Kentos998 18 апр. 2014 г., 7:06:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
May54
18 апр. 2014 г., 8:10:42 (10 лет назад)

1) var a,b,r,i:longint; begin Readln(a,b); If a> b then begin r:=a;a:=b;b:=r;end; For i:=a to b do Writeln(I); end. 2) var a,b,i:longint; begin Readln(a,b); For I:=a to b do If I mod 2<>0 then writeln(i); End. 3) var a,b,i,s,symm:longint; begin Readln(a,b); s:=0;symm:=0; For I:=a to b do begin If I mod 2<>0 then s:=s+I; If I mod 3=0 then symm:=symm+I; End; Writeln(s,symm); end. 4) var r,p,a,n,i:longint; begin readln(a,n); r:=n; If n<0 then r:=-n; p:=1; for i:=1 to r do p:=p*a; if n<0 then writeln(1/p) else writeln(p); end.

+ 0 -
Bashkencia
18 апр. 2014 г., 10:34:37 (10 лет назад)

Ща

Ответить

Другие вопросы из категории

вам предложили заменить телефон 1 на телефон 2. данные устройства обладают приблизительно одинаковыми техническими характеристиками, набором сервисов.

в телефоне 1 накоплено немало мультимедиа информации на дополнительном чипе памяти. выбери правильное и наиболее простое средство передачи информации в телефон 2.

1)Wi-Fi канал

2) система мобильной передачи данных

3) GPS система обмена данными

4) карта оперативной памяти micro SD. помогите пожалуйста....

Читайте также

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

1. Дано n целых чисел. Вывести все числа, меньшие последнего числа в ряду;

2. Определите, есть ли в массиве числа от 3 до 7. Укажите их номер.








Вы находитесь на странице вопроса "1) Вывести все числа от a до b,но заранее неизвестно, a&gt;b или a&lt;b", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.