Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти сумму

10-11 класс

элементов массива с четными индексами, значение которых превышает К.(паскаль)

Danilka2510 06 июня 2014 г., 9:30:27 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
95Катюшка95
06 июня 2014 г., 10:21:44 (9 лет назад)

uses crt;
const n=20;
var a:array[1..n] of integer;
s,k,i:integer;
begin
for i:=1 to n do
read(a[i]);
readln(k);
s:=0;
for i:=1 to n do
if (i mod 2=0) and (a[i]>k) then s:=s+a[i];
writeln(s);
end.

Ответить

Другие вопросы из категории

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Задача с циклами:

Вычислить сумму четных целых чисел из [n,m].

Читайте также

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

1) Найти сумму четных элементов массива F(12), значения которых больше 2. Вывести также число таких элементов, массив расположен в ячейках D2:D14 листа

Сумма.
Массив: -7 0 3 1 -8 -3 5 3 12 15 40 7

2) Определить в Exel адрес первого числа больше 2.



Вы находитесь на странице вопроса "Найти сумму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.