Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

3. Таблица футбольного чемпионата задана квадратной матрицей, в которой все элементы главной диагонали являются нечисловыми элементами, а остальные

10-11 класс

элементы определяются по правилу: 2- выигрыш, 1- ничья, 0- проигрыш. Определить названия команд, прошедших чемпионат без поражений. Определить лидера.

Лиза5522 19 янв. 2015 г., 10:52:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Таня13042000
19 янв. 2015 г., 12:49:16 (9 лет назад)

вот программа на языке PASCALABC

uses crt;
const max=20;
var a:array [1..max,1..max] of byte;
n,i,j,k,s,s1,s2,s3:integer;
x:char;
begin
x:=x;
repeat
Writeln('vvedite kol-vo komand N');
Readln(N);
until N in [1..max];
for i:=1 to N do
for j:=1 to N do
A[i,j]:=random(3);
For i:=1 to N do
begin
for j:=1 to N do
if i=j then write(#204:4)
else Write(a[i,j]:4);
writeln;
end;
writeln('íîìåðà êîìàíä, èìåþùèõ áîëüøå ïîáåä íà ÷óæîì ïîëå');
k:=0;
s:=0;
s3:=0;
for i:=1 to n do
begin
for j:=1 to n do
begin
if a[i,j]=2 then s1:=s+1;
if a[j,i]=0 then s2:=s3+1;
s:=s1;
s3:=s2;
end;
end;
if s2>s1 then
begin
writeln('Nomer komandy - ',i,' Kol. pobed = ',s2);
k:=1
end;
if k=0 then writeln('takih komand net');
end.

Ответить

Другие вопросы из категории

Помогите решить пожалуйста)
дан массив действительных чисел,размерность которого N.

Подсчитать,сколько в нем отрицательных,положительных и нулевых элементов. Программа в паскаль

Читайте также

написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица

NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.

помогите пожалуйста очень надо!!!

Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его с элементом главной диагонали.
(на паскале)

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно

Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на

четных местах в строке на “ * ”, а элементы стоящие на нечетных местах в строке на ноль.



Вы находитесь на странице вопроса "3. Таблица футбольного чемпионата задана квадратной матрицей, в которой все элементы главной диагонали являются нечисловыми элементами, а остальные", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.