Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дан массив из n элементов,определить каких элементов больше(отрицательных,положительных или =0)

5-9 класс

Tvinkol 12 сент. 2016 г., 16:44:54 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лах228322
12 сент. 2016 г., 19:42:35 (7 лет назад)

program aliona;
const n =10;
var a:array[1..n] of integer;
i:integer;
begin
writeln('vvedite massiv');
for i:=1 to n do
readln(a[i]);
for i :=1 to n do
 begin
if ((a[i]>0) >(a[i]<0))  then
writeln ('polojitelnih cisel bolise')
else
writeln('otritatelinih cisel bolise');
if ((a[i]=0)>(a[i]>0))and ((a[i]=0)>(a[i]<0))
 then
writeln('bolise nulei');
  end;
readln;
end.

Ответить

Другие вопросы из категории

напишите программу на Паскаленапишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 4 и

оканчивающихся на 8. Программа получает на вход натуральные числа, кол-во введеных чисел неизвестно, последовательность чисел оканчивается числом 0 (ноль-признак окончания ввода, не входит в последовательность) кол-во чисел не превышает 100. введеные числа не превышают 300. Программа должна вывести одно число: сумму всех чисел кратных 4 и оканчивающихся на 8.

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Решите пожалуйста хоть что-нибудь. Массивы. 1.Дан массив, какое число встретится раньше максимальное или минимальное?

2.Даны 2 массива одинакового размера. Сформировать 3-й массив, каждый элемент которого равен минимальному из элементов с одинаковыми номерами.
3.Заполнить массив из 11 элементов числами 1, 2,3,..,11.
Заранее спасибо.



Вы находитесь на странице вопроса "дан массив из n элементов,определить каких элементов больше(отрицательных,положительных или =0)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.