Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Последовательность Фибоначчи определяется следующим образом:первые два члена последовательности равны 1,а каждый следующий равен сумме двух

10-11 класс

предыдущих.То есть числами Фибоначчи являются 1,1,2,3,5,8,13,... .Определить N-е по порядку числа Фибоначчи.Помогите решить в Pascal пожалуйста)

Aruna23 26 дек. 2016 г., 16:56:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
StrileckaVikto
26 дек. 2016 г., 19:15:42 (7 лет назад)

var a:array[0..2] of integer;

   i, n: integer;

begin

   a[1]:=1;

   a[2]:=1;

   readln(n);

   for i:=3 to n do

      a[i mod 3] := a[(i-1) mod 3] + a[(i-2) mod 3];

   writeln(a[n mod 3])

end.

+ 0 -
Rancena
26 дек. 2016 г., 21:37:33 (7 лет назад)

Program z;

var A:array [1..1000] of integer;

      n,i:integer;

Begin

readln(n);

A[1]:=1;

A[2]:=1;

for i:=3 to n do

      A[i]:=A[i-1]+A[i-2];

writeln(A[n]);

end.

Ответить

Читайте также

Последовательность чисел Фибоначчи образуется так: первый и второй члены последовательности равны единице, каждый следующий член равен сумме двух

предыдущих. (1,1,2,3,5,13...).Дано натуральное число n. n>=3. а)Найти k-й член этой последовательности; б)Для заданного n определить верно ли, что сумма первых n-членов последовательности есть четное число. Помогите, нужно составить программу для решения данных задач!

Написать программу в Паскале. Последовательность фибоначчи образуется так:первый и второй члены равны 1,каждый следующий равен сумме двух

предыдущих(1,1,2,3,5,8,13,...)найти числа последовательности фибоначчи сумма которых меньше пятизначного числа n.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

Составить программу

вычисления суммы первых N
членов последовательности заданной функцией


А(к)=К2/(К2+1), где К - номер
элемента последовательности.



Вы находитесь на странице вопроса "Последовательность Фибоначчи определяется следующим образом:первые два члена последовательности равны 1,а каждый следующий равен сумме двух", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.