Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу нахождения факториала:

10-11 класс

1) n!
2)1!+2!+3!+...+n!
3)1!+3!+5!+...+(2n-1)!

Ksenyashikina 04 февр. 2017 г., 22:36:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KotGrigor5
05 февр. 2017 г., 0:14:35 (7 лет назад)

program zadanie1;
var n:integer;
        rn:int64;
{------------------------}
function f(arg:integer):int64;
var fi:integer;
begin
        f:=1;
        for fi:=1 to arg do begin
                f:=f*fi
        end
end;
{------------------------}
begin
        readln(n);
        rn:=f(n);
        writeln(rn);
        readln
end.

Ответить

Другие вопросы из категории

Человек говорит в среднем 8 часов в день и его речь

может быть записана 10*118 символами в час. Вычислить информационный объем
произнесенных человеком слов за 1 год.

Последовательность Фибоначчи определяется следующим образом:первые два члена последовательности равны 1,а каждый следующий равен сумме двух

предыдущих.То есть числами Фибоначчи являются 1,1,2,3,5,8,13,... .Определить N-е по порядку числа Фибоначчи.Помогите решить в Pascal пожалуйста)

Упростить логическое выражение

(X v Z) & ( X v not Z) & ( not Y v Z)=

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу



Вы находитесь на странице вопроса "написать программу нахождения факториала:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.