Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дано целое число N (> 0). Найти значение выражения

10-11 класс

1.1 – 1.2 + 1.3 – …
(N слагаемых, знаки чередуются). Условный оператор не использовать. помогите, пожалуйста, через паскаль

Tomirisbolatova 10 марта 2017 г., 14:04:31 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gugninakaty
10 марта 2017 г., 14:48:07 (7 лет назад)

var
  i, n: integer;
  sign, val, sum: real;
begin
  sign := 1;
  val := 1.1;
  writeln('Введите "n": ');
  readln(n);
  for i := 1 to n do
  begin
    sum := sum + sign * val;
    sign := sign * -1;
    val := val + 0.1;
  end;
  writeln('Результат: ',sum);
end.

Ответить

Другие вопросы из категории

Для учета посещаемости детей каждому ученику присвоен код, состоящий из 7 символов ( в записи кода используется строчные латинские буквы - 26 и цифры от

0 до 9). Каждый код сохраняется в память считывающегося устройства на входе в школу с помощью одинакового целого и минимально возможного количества бит. Сегодня в школу пришли 256 учащихся. Сколько информации было сохранено в памяти устройства в байтах?

помогите решить массивы!
-сущность объемного (алфавитного) подхода к измерению информации -связь между размером алфавита и информационным весом символа (в приближении

равновероятности символов)

- связь между единицами измерения информации: бит, байт, Кб, Мб, Гб

- сущность содержательного (вероятностного) подхода к измерению информации

- определение бита с позиции содержания сообщения

Помогите пожалуйста.

Задача в Pascal.
Дано целое число х - цена 1 кг конфет. Вывести стоимость 1, 2,........ 10 гк конфет .

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

For13°. Дано целое число N (> 0). Найти значение выражения

1.1 – 1.2 + 1.3 – …
(N слагаемых, знаки чередуются). Условный оператор не использовать.
ЧЕРЕЗ БЭЙСИК ЖЕЛАТЕЛЬНО



Вы находитесь на странице вопроса "Дано целое число N (> 0). Найти значение выражения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.