Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны 50 чисел. Найти их среднее арифметическое. На Паскале, помогите пожалуйста!

10-11 класс

Sashaok123 19 мая 2013 г., 15:19:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Нато4ка
19 мая 2013 г., 16:57:46 (10 лет назад)

const n = 50;

var
  a :array [1..n] of integer;
  i, sum :integer;
  sr :real;
 
begin

  randomize;
  for i:= 1 to n do
    a[i]:= random(100);
   
  for i:= 1 to n do
    sum:= sum + a[i];
  sr:= sum/n;
  writeln(sr);

end.

Ответить

Другие вопросы из категории

Текст рассказа набран на компьютере. Информационный объем получившегося файла 15 Кбайт. Текст занимает 10 страниц, на каждой странице одинаковое

количество строк, в каждой строке 64 символа. Все символы представлены в кодировке Unicode. Определите, сколько строк помещается на каждой странице.
1) 48 2) 24 3) 32 4)12
C решением, пожалуйста.

Добрый вечер!

Помогите пожалуйста, нужно составить блок схем и написать программу для вычисления значения следующего выражения:
Очень нужно! Заранее спасибо!

Читайте также

Написать программу на С++. Дана целочисленная квадратная матрица произвольной размерности. Сформировать одномерный массив, в который поместить элементы

двумерной матрицы, находящиеся над побочной диагонали; упорядочить их по возрастанию и найти их среднее арифметическое.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если первое число четно, то выведите сумму этих четырех чисел.
Если второе и третье числа положительны,то выведите их среднее арифметическое.
Если выполняются одновременно два перечисленных выше условия, то выведите все четыре числа без изменения.
Иначе, выведите числа, противоположные исходным.
Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа. Найдите среднее арифметическое значение

среди последних 9-ти элементов массива, максимум среди первых 5-ти элементов. Замените в массиве все элементы, которые больше найденного среднего арифметического - на максимум.



Вы находитесь на странице вопроса "Даны 50 чисел. Найти их среднее арифметическое. На Паскале, помогите пожалуйста!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.