Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать на паскале программу на признак делимости, которая выводит, делится ли число на 11 или нет, с участием функции

10-11 класс

Miheeva534 02 февр. 2014 г., 14:53:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mbayguzhina
02 февр. 2014 г., 16:48:45 (10 лет назад)

То, что написал Alex - это не функция проверки признака делимости,
а стандартная функция остатка от деления, которая тебе не подходит.
Признак делимости на 11 такой. Нужно отдельно сложить цифры, стоящие на нечетных местах - 1, 3, 5, ..., до конца, и отдельно цифры, стоящие на четных местах - 2, 4, 6, ..., тоже до конца.
Потом вычитаешь из большего числа меньшее. Если разность = 0 или делится на 11, то и все число делится на 11.
Я паскаль плохо знаю, поэтому опишу только алгоритм.
1) Вводим начальное число N.
2) Объявляем массив M[length(N)] длиной, равной количеству цифр числа.
3) Делаем в цикле a := N mod 10; M[i] := a; N := int(N / 10); i := i+1;
Продолжаем цикл до тех пор, пока N > 0.
4) S1 := 0; Цикл от 1 до length(N) с шагом 2: S1 := S1 + A[i];
5) S2 := 0; Цикл от 2 до length(N) с шагом 2: S2 := S2 + A[i];
6) Raznost := abs(S1 - S2); 
7) Если Raznost mod 11 = 0 тогда ответ ДА, иначе ответ НЕТ.
8) Конец

+ 0 -
Kolesoc
02 февр. 2014 г., 17:59:52 (10 лет назад)

var
chislo:integer;
begin
writeln('Введите число');
readln ( chislo);
if ( (chislo mod 11)=0) then
writeln ( 'делится')
else
writeln ( 'не делится');
readln;
readln
end.
вроде так
будут ошибки пиши

Ответить

Другие вопросы из категории

Excel в переводе чего означает
Все ученики старших классов (с 9-го по 11-й) участво­вали в

школьной спартакиаде. По результатам соревнований каждый из них получил
от 0 до 3-х баллов. На диаграмме I отражено распределение учеников по
клас­сам, а на диаграмме II — количество учеников, набравших бал­лы от 0
до 3-х. На обеих диаграммах каждый ученик учтён толь­ко один раз.

Имеются четыре утверждения:

1 ) Среди учеников 9-го класса есть хотя бы один, набравший 2 или 3 балла.
2 ) Все ученики, набравшие 0 баллов, могут быть 9-классниками.
3 ) Все 10-классники могли набрать ровно по 2 балла.
4 ) Среди набравших 3 балла нет ни одного 10-классника.
Какое из этих утверждений следует из анализа обеих диа­грамм?

Читайте также

Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли

оно четным или отрицательным.(Паскаль)

Или так: Из 16 -ти чисел,сделайте для каждого вывод,является ли оно четным или отрицательным .(Паскаль)

Помогите пожалуйста,оченьььь срочно надо!Буду благодарна за решение ,спасибо!!!!!!!

Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число

на входе и выводит сумму его цифр.

Я написал первую часть программы (без вывода суммы цифр) :

program sg3;

uses crt;

var i,a,k: integer;

begin

clrscr;

write('Введите число: ');

readln(a);

k:=0;

for i:=2 to a div 2 do

if a mod i =0 then k:=k+1;

if k=0 then write('Простое')

else writeln('Составное');

readln;

end.

Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))



Вы находитесь на странице вопроса "Написать на паскале программу на признак делимости, которая выводит, делится ли число на 11 или нет, с участием функции", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.