Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано натуральное число. Если в нём есть цифры a и b, то определить какая из них расположена в числе правее. Если одна или обе эти цифры встречаются в

5-9 класс

числе несколько раз, то должны быть учтены самые правые из одинаковых цифр.
(паскаль)

Alevtina2005 29 июля 2014 г., 22:12:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ainazaisaeva
29 июля 2014 г., 22:49:14 (9 лет назад)

var
   a,b,n:string;
   i:integer;
begin
write('Введите n: ');
readln(n);
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
for i:=length(n) downto 1 do
  if (n[i]=a) or (n[i]=b) then
     begin
    writeln('Правее ',n[i]);
    halt;
    end;
end.

Ответить

Читайте также

У исполнителя Удвоитель две команды, которым присвоены номера: 1. умножь на 2 2. прибавь 3 Первая из них увеличивает число на

экране 2 раза, вторая - прибавляет к числу 3.

Составьте алгоритм получения из числа 1 числа 38, содержащий не более 5 команд. В ответе запишите только номера команд.

(Нопример, 12211 - это алгоритм:

умножь на 2

прибавь 3

прибавь 3

умножь на 2

умножь на 2

который преобразует число 1 в 32.)

Если таких алгоритмов более одного, то запишите любой из них.

У исполнителя Утроитель две команды, которым присвоены номера: 1. умножь на 3, 2. вычти 2. Первая из них увеличивает число на экране в 3 раза, вторая

уменьшает его на 2. Запишите порядок команд в программе преобразования числа 3 в число 23, содержащей не более 4 команд, указывая лишь номера команд. (Например, 21211 -- это программа умножь на 3 прибавь 1 умножь на 3 прибавь 1 прибавь 1, которая преобразует число 1 в 14.) (Если таких программ более одной, то запишите любую из них Можно с объяснением

у исполнителя Арифметики 2 команды,которым присвоены номера: 1)прибавь 2 2)умножь на 3.Первая из них увеличивает число на экране на 2,вторая утраивает

его. запишите порядок команд в программе преобразования числа 12 в число 122,содержащей не более одной,то запишите любую из них. Ребят прошу объяснить и решить,очень надо,СРОЧНО!ПОМОГИТЕ ПОЖАЛУЙСТА!ОЧЕНЬ ОЧЕНЬ НАДООО!ПЛИИИЗ

Написать программу на паскале.

Даны три числа m, n, p. Определить какое из них равно d. Если ни одно не рано d, то найти max(d-m, d-n, d-p)



Вы находитесь на странице вопроса "Дано натуральное число. Если в нём есть цифры a и b, то определить какая из них расположена в числе правее. Если одна или обе эти цифры встречаются в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.