Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

задано масивA (-64;35;-12;0;17;121;-28;0;95;2;-4;31;27;-144;33;60;-48;0;-56;65) Побудувати блок-схему алгоритму написати Amin елементу масиву А.Вивести

10-11 класс

на екран масив А та значення Аmin

Taichka1702 05 авг. 2016 г., 13:11:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyaoberemko
05 авг. 2016 г., 14:31:49 (7 лет назад)

uses crt;
const a: array[1..20] of integer=(-64,35,-12,0,17,121,-28,0,95,2,-4,31,27,-144,33,60,-48,0,-56,65);
var min,i:integer;
begin
min:=a[1];
for i:=1 to 20 do
begin
if min > a[i+1] then min:= a[i+1];
writeln(a[i]);
end;
writeln(min);
readln;
end.

Ответить

Читайте также

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Сформировать двумерный массив M(3,4) чисел 22,3,5,7,12,15,17,8,9,1,23,45; Вывести на экран в виде таблицы; Найти максимальные и минимальные значения .

Заменить элементы первой строки на нули. ПОМОГИТЕ ПОЖАЛУЙСТА ОЧЕНЬ НАДО!!!!!

алгоритм Мишень цел n, k, i вещ массив P[1000] вещ r1, r2 начало ввести

n, массив P и радиусы r1, r2 /* Исходные данные */

вывести заголовок задачи и значения n, P, r1, r2 k ¬0 для i от 1 до n шаг 1 выполнять/*

Подсчитать число точек */ если r1 < ri и ri < r2 то k ¬k +1

конец-если

конец-цикл

вывести заголовки выходных данных и значений k конец

Теперь спланируем тестирование.

Проверку программы выполним при следующих исходных данных.

Зададим число точек на плоскости: n = 10. Подберем расстояния и радиусы: 0.03 21.0 12.89 7.41 99.99

P = 12.34 56.78 90.98 7.6 0.54

r1 = 12.35 r2 = 56.90.

Выходные данные в этой задаче будут иметь вид: Мишень Исходные данные:

n= 10 Массив P[n]: 0.03 21.0 12.89 7.41 99.99 12.34 56.78 90.98 7.6 0.54 r1 = 12.35 r2 = 56.90

Ответ: внутри 3 точки (три точки находятся внутри кольца).помогите написать программа в паскале и алгоритм блок-схему.пожалуйста срочно!



Вы находитесь на странице вопроса "задано масивA (-64;35;-12;0;17;121;-28;0;95;2;-4;31;27;-144;33;60;-48;0;-56;65) Побудувати блок-схему алгоритму написати Amin елементу масиву А.Вивести", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.