Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан одномерный массив m состоящий из 12 целых чисел. Организовать

10-11 класс

ввод массива случайным образом и найти:
1) количество нулевых элементов;
2) сумму элементов меньших 1

Nikolakarpekin 29 янв. 2017 г., 19:36:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinadobrova20
29 янв. 2017 г., 20:41:00 (7 лет назад)

const  n = 12;
var  m :array [1..n] of integer;  i, kol, sum :integer;
begin
  randomize;  for i:= 1 to n do    m[i]:= random(100)-50;    sum:= 0; kol:= 0;  for i:= 1 to n do  begin    if m[i] = 0 then      inc(kol);    if m[i] < 1 then      sum:= sum + m[i];  end;  writeln('Количество нулевых элементов: ',kol);  writeln('Сумма элементов, меньших 1: ',sum);
end.

Ответить

Другие вопросы из категории

Help! Нужно построить блок-схему:(

function f(x:
real): real;

begin

if x < 0 then
f := exp(x * ln(3)) + sqr(x)

else f := exp(-x
* ln(3)) - sqr(-x)

end;



var

a, b, h, x, y:
real;



begin

a := -1; b := 2;
h := 0.2;

writeln('':10,
'_________________');

writeln('':10,
'| x
| y |');

Часть страниц журнала мод является цветным изображением в 128-цветной палитре и в формате 320x540 точек;

страницы, содержащие текст, имеют формат -16 строк по 64 символа в строке. Сколько страниц журнала можно сохранить на жёстком диске объёмом 15 Гбайт, если каждая четвёртая страница - цветное изображение

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему. Дан одномерный массив А состоящий из 10

элементов.Вывести на экран исходную таблицу и резултат программы.

Найти произведения элементов массива А. удовлетворяющих условию:

c<=A[i]<=d.



Вы находитесь на странице вопроса "Дан одномерный массив m состоящий из 12 целых чисел. Организовать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.