Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны два массива состоящих каждый из 8 ценах чисел, в каком массиве больше элементов кратных 5

10-11 класс

Bekosyamariko 17 июля 2013 г., 15:20:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andesten
17 июля 2013 г., 17:47:56 (10 лет назад)

Pascal
Var a, b : array [1..8] of longint ;
k1,k2,i: longint ;
Begin
For i:=1 to 8 do
Read (a[i]);
For i:=1 to 8 do
Read(b[i]);
For i:= 1 to 8 do
Begin
If a[i] mod 5=0 then k1:=k1+1;
If b[i] mod 5=0 then k2:=k2+1;
End;
If k1<k2 then writeln ('vo 2 massive bolhe') else if  k1>k2 then writeln ('v 1 mssive bolhe') else writeln ('ravno');
End.

Ответить

Другие вопросы из категории

1. Представьте информацию в структурном виде так, чтобы ее было легче воспринимать:

«Озеро Байкал находится на юг Восточной Сибири. Длина озера 636 км, ширина 80 км, площадь 31 722 км², объём 23 615,390 км³. Длина береговой линии Байкала примерно 2100 км. Байкал – самое глубокое озеро на Земле, его глубина 1642 м. В Байкал впадает 336 рек, в том числе Селенга, Верхняя Ангара, Баргузин. Вытекает из Байкала единственная река – Ангара».

в виде таблицы

1. В таблице приведены запросы и количество найденных по ним

страниц некоторого сегмента сети Интернет:




Запрос

ЕГЭ 2012. А5. Автомат получает на вход два двузначных восьмеричных числа. По этим числам строится новое восьмеричное число по следующим

правилам.

1. Вычисляются два восьмеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел.

2. Полученные два восьмеричных числа записываются друг за другом в порядке убывания (без разделителей).

Пример. Исходные числа: 66, 24. Поразрядные суммы: 10, 12. Результат: 1210.

1) 112

3) 129

Объясните пожалуйста пример, почему они так складывают, разве не так: 6+2 и 6+4 ? И почему не подходит 3 вариант.

Синоптик предсказал погоду следующим образом. Если будет южный ветер или не будет северного ветра, то будет дождливо и не будет холодно. Если

ветра южного не будет, то не будет пасмурно или пойдет дождь. Если все же будет южный ветер, то будет пасмурно, но дождя не будет. Если не будет северного ветра или не будет холодно, то задует южный ветер и будет пасмурно. Какую погоду предсказал синоптик?( Напишите решение, пожалуйста, ответ я и так знаю)

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1.Даны два массива: А(5) и В(5). Сформируйте из них массив С,предварительно определив его длину,включая попеременно из массива А положительные

элементы, а из массива В -нечетные по значению.Выведите на экран массивы А,В,С.

2.Информация о площадях и средней урожайности хранится в массиве,где каждый элемент с четным индексом - засеянная площадь, а с нечетным - урожайность.Определите и выведите на экран кол-во собранной пшеницы и среднюю урожайность.

Помогите пожалуйста!



Вы находитесь на странице вопроса "Даны два массива состоящих каждый из 8 ценах чисел, в каком массиве больше элементов кратных 5", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.