Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

даны числа C и D . Если C кратно D , то найти их сумму , иначе проезведение

10-11 класс

Plpewka2255 31 мая 2013 г., 13:52:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Никитавпввпв
31 мая 2013 г., 16:52:00 (10 лет назад)

Program Zadacha;
Var C, D: Integer;
Begin
Write('C = ');
ReadLn(C);
Write('D = ');
ReadLn(D);
If(D = 0) Then
WriteLn(C * D)
ElseIf (C Div D > 0) And (C Mod D = 0) Then
WriteLn(C + D)
Else
WriteLn(C * D);
ReadLn;
End.

Ответить

Другие вопросы из категории

Синоптик предсказал погоду следующим образом. Если будет южный ветер или не будет северного ветра, то будет дождливо и не будет холодно. Если

ветра южного не будет, то не будет пасмурно или пойдет дождь. Если все же будет южный ветер, то будет пасмурно, но дождя не будет. Если не будет северного ветра или не будет холодно, то задует южный ветер и будет пасмурно. Какую погоду предсказал синоптик?( Напишите решение, пожалуйста, ответ я и так знаю)

Сколько секунд потребуется модему, передающему сообщения со скоростью 32000 бит/с, чтобы передать 16-цветное растровое

изображение размером 800х600 пикселей, при условии, что в каждом байте закодировано максимально возможное количесто пикселей

дан алгоритм X:=1;y:=5;x:=2*x;y:=y-1.Все ли команды этого алгоритма обязательно должны выполняться дискретно-последовательным способом? можно ли

производить выполнение каких-то команд в один и тот же промежуток времени?

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

• Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления:


1) 164.25
2) 520,375

• Перевести данное число в десятичную систему счисления:
1) 1110010100,1011001 (двоичная СС)
2) 1000000110,00101 (двоичная СС)
3) 666,16 (восьмеричная СС)
4) 1C7,68 (шестнадцатеричная СС)
*СС - система счисления.



Вы находитесь на странице вопроса "даны числа C и D . Если C кратно D , то найти их сумму , иначе проезведение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.