Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль. Разработать алгоритм и программу с массивами, 3-мя способами ввода:

10-11 класс

1)Рандомно
2)Ввод через клавиатуру
3)Формулой
Желательно, всё это сделать одной программой.
числа любые

Nsarano 13 сент. 2013 г., 23:29:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pionerskii
14 сент. 2013 г., 1:56:12 (10 лет назад)

const
  n = 10;

var
  a: array[1..n] of integer;
  i: integer;

begin
  { 1 }
  Write('Введите элементы массива через пробел ');
  for i := 1 to n do Read(a[i]);
  Writeln('*** Элементы массива 1 ***');
  for i := 1 to n do Write(a[i]:5);
  Writeln;
  { 2 }
  Randomize;
  Writeln('*** Элементы массива 2 ***');
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i]:5)
  end;
  Writeln;
  { 3 }
  Writeln('*** Элементы массива 3 ***');
  for i := 1 to n do
  begin
    a[i] := (35 * i - 12) mod 13;
    Write(a[i]:5)
  end
end.

Тестовое решение:

Введите элементы массива через пробел 4 -7 12 7 34 0 7 -8 23 -12
*** Элементы массива 1 ***
    4   -7   12    7   34    0    7   -8   23  -12
*** Элементы массива 2 ***
  -20   38   33  -20  -25    6   15   36   12    7
*** Элементы массива 3 ***
   10    6    2   11    7    3   12    8    4    0


Ответить

Другие вопросы из категории

Теплоход расчитан на a пассажиров и b членов комманды.Каждая спасательная шлюпка может вместить c человек . Какое наименьшее число шлюпок должно быть на

теплоходе чтобы в случае необходимости в них можно было разместить всех пассажиров и всех членов комманды (a=1000,b=30,c 50

1. Представьте информацию в структурном виде так, чтобы ее было легче воспринимать:

«Озеро Байкал находится на юг Восточной Сибири. Длина озера 636 км, ширина 80 км, площадь 31 722 км², объём 23 615,390 км³. Длина береговой линии Байкала примерно 2100 км. Байкал – самое глубокое озеро на Земле, его глубина 1642 м. В Байкал впадает 336 рек, в том числе Селенга, Верхняя Ангара, Баргузин. Вытекает из Байкала единственная река – Ангара».

в виде таблицы

1. В таблице приведены запросы и количество найденных по ним

страниц некоторого сегмента сети Интернет:




Запрос

Читайте также

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Помогите решить, очень нужно... 2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных

элементов.
3. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.



Вы находитесь на странице вопроса "Паскаль. Разработать алгоритм и программу с массивами, 3-мя способами ввода:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.