Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

придумайте программу в Паскаль ABC для вычисления следующей величины:

10-11 класс

1+а+а^2+K+a^K
а и К задаются пользователем.

Minerliv 07 мая 2014 г., 10:43:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мдаясдохну
07 мая 2014 г., 12:02:27 (9 лет назад)

var n,k:real;
begin
readln(n,k);
writeln(sqr(n)+k+exp(ln(n)*k)+n+1);
end.

Функция exp(ln(n)*k) возводит число n в степень k

+ 0 -
Milanaamirasta
07 мая 2014 г., 14:32:31 (9 лет назад)

program _4_2;var
s1,a,d:real;

k,i,n: integer;
begin
writeln('Ââåäèòå A');
readln(a);
writeln('Ââåäèòå K');
readln(k);
d:=a;
for i:=1 to k do
begin
d:=a;
d:=d*a;
writeln('d=',d);
end;
s1:=1+a+(a*a)+k+d;
writeln('s1=',s1);
end.

+ 0 -
Natalisoloveva1
07 мая 2014 г., 17:30:39 (9 лет назад)

вот мой вариант программы, но он не верно возводит А в степень Кprogram _4_2;
var
s1,a,d:real;

k,i,n: integer;
begin
writeln('Ââåäèòå A');
readln(a);
writeln('Ââåäèòå K');
readln(k);
d:=a;
for i:=1 to k do
begin
d:=a;
d:=d*a;
writeln('d=',d);
end;
s1:=1+a+(a*a)+k+d;
writeln('s1=',s1);
end.

Ответить

Другие вопросы из категории

Помогите срочно!!!!!! Срочноооооо!
3)Известно количество страниц, которые находит поисковый сервер по следующим запросам:

Собаки 200 кошки | собаки 450
Кошки 250 Кошки & лемуры 40
Лемуры 450 Собаки & лемуры 50.

Сколько страниц найдет этот сервер по запросу
кошки | собаки | лемуры?

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

ЛБ- 70 Разработайте алгоритм для вычисления площади треугольника: s = 1/2ah, где а – длина основания треугольника, h – его высота.

ВБ- 71 Разработайте схему алгоритма, который проверяет, не превосходит ли сумма двух действительных чисел А и В числа 100. Если не превосходит, установить значение флага F=0, иначе установить значение флага F=1. Вывести значение F.

ЦА-10 Разработайте схему алгоритма для вычисления суммы S первых n целых чисел. Предусмотрите ввод значения n с клавиатуры. Текущее значение целого числа имеет имя i (i = 1, 2, .., n).



Вы находитесь на странице вопроса "придумайте программу в Паскаль ABC для вычисления следующей величины:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.