Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Между населенными пунктам A,B,C,D,E,F,Z построены дороги протяженность которых приведена в таблице(отсутствие числа в таблице означает, что прямой

10-11 класс

дороги между пунктами нет)

A B C D E F Z

A 7 57

B 7 5 7 27

C 5 3

D 7 3 2

E 27 2 2 8

F 2 3

Z 57 8 3

Определить длину кратчайшего пути между пунктами AиZ (при условии что передвигаться можно только по построенным дорогам)
1)21
2)24
3)42
4) 57
Пожалуйста с подробным решением

Karen3 07 мая 2014 г., 17:14:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Outlaw
07 мая 2014 г., 19:13:24 (9 лет назад)

1) Из А только два пути - AB=7, AZ=57.

AZ слишком большой, для начала отбросим его.

Идём по AB=7.

 

2) Из B три пути: BC=5, BD=7, BE=27.

BE слишком большой, пока отбросим его.

2.1) Рассмотрим для BC=5 :

Из C есть только один путь, CD=3.

Рассмотрим для CD :

Из D есть DB, но нам незачем возвращаться; значит остаётся DE=2.

Рассмотрим для DE :

Из Е есть EB, но это возврат, есть EF=2 и EZ=8

2.1.1) Если мы идём по EF, то от F есть FZ=3

В итоге, получается: A-B-C-D-E-F-Z = 7+5+3+2+2+3 = 22

2.1.2) Если в предпоследнем шаге пойти по EZ=8, то получается A-B-C-D-E-Z = 7+5+3+2+8 = 25

 

2.2) Рассмотрим для BD=7

Этим шагом мы как бы перескочим B-C-D

Из D есть DC и DE, идти в С нет смысла, так что идём в DE=2

Из Е есть EF=2 и EZ=8

2.2.1) Для начала пойдём в EF=2, FZ=3

Получается A-B-D-E-F-Z = 7+7+2+2+3 = 21

 

2.2.2) Другой вариант, EZ=8

Получается A-B-D-E-Z = 7+7+2+8 =24

 

Ответ уже найдет, выделен жирным, но в других задачах иногда нужно просмотреть абсолютно все пути.

Ответить

Другие вопросы из категории

придумайте программу в Паскаль ABC для вычисления следующей величины:

1+а+а^2+K+a^K
а и К задаются пользователем.

Помогите срочно!!!!!! Срочноооооо!
3)Известно количество страниц, которые находит поисковый сервер по следующим запросам:

Собаки 200 кошки | собаки 450
Кошки 250 Кошки & лемуры 40
Лемуры 450 Собаки & лемуры 50.

Сколько страниц найдет этот сервер по запросу
кошки | собаки | лемуры?

Читайте также

Написать программу вычисления расстояния между населенными пунктами, изображенными на карте. Ниже представлен рекомендуемый вид экрана во время

работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Написать программу ПАСКАЛЬ вычисления расстояния между населёнными пунктами. 1)Вычислите расстояние между населёнными пунктами. 2)введите

исходные данные

3)масштаб карты 120 (кол-во км в одном см)

4)расстояние между точками изображающими населённые пункты если между ними 3.5 (см)...(должно выйти 420км)

5) расстояние между насел. пунктами ... км

Напишите пожалуйста программу. К завтрашнему дню надо. С Паскалем проблемы

помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже

билетов. Пусть населенные пункты обозначены номерами 1, 2, 3, 4, 5, 6, 7, 8. Стоимость одного билета к конкретному пункту определена так:

22,k=1

35,k=2,3

50,k=4

72,k=5,6

97 во всех остальных случаях.

Сколько будут стоить m билетов к некоторому населенному пункту? Для решения задачи используйте алгоритмическую конструкцию "выбор" (case).

program z5;

var

r, m, n, s:integer;

begin

writeln('r=', r);

readln(r);

writeln('m=', m);

readln(m);

case r of

1:n:=22;

2,3:n:=35;

4:n:=50;

5,6:n:=72;

else n:=97;

end;

s:=m*n;

writeln('s=', s);

end.

1)Региональная метеостанция фиксирует годовые атмосферные осадки в 128 населенных пунктах. За 5 лет наблюдений колебания осадков были в интервале от

100 до 900 мм. Специальное устройство записывает величину осадков в двоичном коде с использованием минимально возможного количества битов. Каков информационный объем (в байтах) всех данных, записанных устройством за эти годы? В ответе укажите только число.

решите пожалуйста в паскале abc . Телефонные разговоры с тремя населенными пунктами стоят с1, с2, с3 коп/мин. Длительность разговоров t1, t2, t3

мин. соответственно. Какую сумму насчитает компьютер к оплате за каждый разговор в отдельности и за все вместе?



Вы находитесь на странице вопроса "Между населенными пунктам A,B,C,D,E,F,Z построены дороги протяженность которых приведена в таблице(отсутствие числа в таблице означает, что прямой", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.